post #1 of Old 04-10-2013, 02:09 PM Thread Starter
blakeKJ
Registered User
2006 KJ Liberty 
 
Join Date: Aug 2011
Location: barrie
Posts: 28
Blower problems :(

Hey everyone,

I've done searches and read threads but none match my problems with my blower.

Symptoms: blows cold and hot air, on all speeds and modes.
A/C is ice cold. Sounds perfect right?

What seems to be randomly, the vent door seems to shut? On its own. You can hear the motor blowing on all speeds. And very slightly feel it seeping through defrost. More on the passenger side than driver.
Even changing from mode to mode, you can hear it change but, no air is coming through.

Very dangerous because the condensation freezes in the winter and Ices the windshield!!!
And my driver window regulator was broken until a month ago. When I changed it my self (2/4)

So, any suggestions?

Cheers

blakeKJ is offline  
post #2 of Old 04-11-2013, 01:12 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, South Africa
Posts: 1,282
Quote:
Originally Posted by blakeKJ View Post
Hey everyone,

I've done searches and read threads but none match my problems with my blower.

Symptoms: blows cold and hot air, on all speeds and modes.
A/C is ice cold. Sounds perfect right?

What seems to be randomly, the vent door seems to shut? On its own. You can hear the motor blowing on all speeds. And very slightly feel it seeping through defrost. More on the passenger side than driver.
Even changing from mode to mode, you can hear it change but, no air is coming through.

Very dangerous because the condensation freezes in the winter and Ices the windshield!!!
And my driver window regulator was broken until a month ago. When I changed it my self (2/4)

So, any suggestions?

Cheers
The air flow is controlled by the Blend Door which is a small motor and by vanes moved by vacuum control.

You can check that the vacuum pipe from the inlet manifold going into the cabin is connected properly to the whole vane setup which is located under the dash and you can test the Blend Door operation as well.

Download the 2006 KJ Service Manuals here for information on how the system works:

http://www.colorado4wheel.com/manuals/Jeep/KJ

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
post #3 of Old 04-11-2013, 08:02 AM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,360
Driving in heavy winds when this does this?

If yes then pretty normal for a KJ as the wind will be entering the fresh air duct to fast if your driving into the wind and the vacuum actuators are on the weak side to maintain the correct mode setting.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #4 of Old 04-11-2013, 09:07 AM Thread Starter
blakeKJ
Registered User
2006 KJ Liberty 
 
Join Date: Aug 2011
Location: barrie
Posts: 28
No, even when I'm parked.

But once it stops working it doesn't work again until it's parked for a while. I've had the car for 3 years. It's a new problem I know that....
blakeKJ is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome