Blower Motor Resistor - AAARGH! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > Blower Motor Resistor - AAARGH!

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 09-24-2013, 10:11 AM   #1
toaster61
Registered User
 
Join Date: Oct 2010
Location: london
Posts: 8
Blower Motor Resistor - AAARGH!

So the blower was only working on settings 3 & 4 and I'd read up how this was common etc. I sourced a replacement BMR thru ebay which seems to be a genuine chrysler part and just fitted it. Pretty easy job which is just as well as now the blower only works on setting #4. It's seated all OK and screwed/clipped in placed.

Before I start moaning to the vendor, is there anything else that could case this problem - the fact that the problem is difefernt (though worse!) now suggest it was the BMR all along doesn't it?

T (in the UK)

toaster61 is offline   Reply With Quote
Unread 09-24-2013, 12:45 PM   #2
2007LIB
Registered User
2007 KJ Liberty 
 
Join Date: Sep 2013
Location: Ajax, Ontario
Posts: 57
Hey toaster, had the same problem..... First it worked on 2,3, &4.. then 3,&4 and then just 4....
4 is the default that bypasses all the resistors and has a direct connection to the fuse box.
I went to the Chrysler dealer and bought a new one with the one year warranty. It cost me less than $30.00 can.
has been working ever since.
2007LIB is offline   Reply With Quote
Unread 09-25-2013, 04:11 AM   #3
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 901
Most guys fit the resistor block from the Chrysler Sebring up to 2005....fits perfectly but is a lot more robust....or else get the Jeep OEM part!
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote
Unread 09-25-2013, 05:07 AM   #4
toaster61
Registered User
 
Join Date: Oct 2010
Location: london
Posts: 8
Thanks - I'm still rather baffled that the new unit could apparently be totally faulty and whether there is some other issue. I prob should refit the old one and see what happens (though I was quite rough getting it out). WIll consider the Sebring option but that model never took on here in the UK (crap reviews) so unlikely I'll find parts.

Cheers,
T
toaster61 is offline   Reply With Quote
Unread 09-25-2013, 08:54 AM   #5
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 901
Quote:
Originally Posted by toaster61 View Post
Thanks - I'm still rather baffled that the new unit could apparently be totally faulty and whether there is some other issue. I prob should refit the old one and see what happens (though I was quite rough getting it out). WIll consider the Sebring option but that model never took on here in the UK (crap reviews) so unlikely I'll find parts.

Cheers,
T

The Sebring was never sold here in SA so I would have to go OEM if needed.
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.