anyone have any ideas? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > anyone have any ideas?

RIGID LED Light Blowout Sale - All Sizes, All Series, all Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineJeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 08-22-2012, 05:53 PM   #1
lunerbator
Registered User
2004 KJ Liberty 
 
Join Date: Aug 2009
Location: Maine
Posts: 3
anyone have any ideas?

i have a 04 liberty 5 speed. i keep getting a check engine light. there are three codes. one is bank 1 sensor 1 lean, bank 2 sensor lean, bank 1 sensor 2 lean.
i have changed both o2 in the rear. my jeep has no power and is getting about 10 miles per gal. it also kicks or bogs down when i need the power. when i get on the turn pike it takes me 1/4 mile to go from 45 - 65 mph. any ideas would be lovely right now.

lunerbator is offline   Reply With Quote Quick reply to this message
Unread 08-22-2012, 08:45 PM   #2
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,171
Well did you change the front O2 sensor as well? Don't use bosch O2 sensors,only use Denso or NTK(NGK) O2 sensors in a Chrysler.

Could also have other issues like bad cats or a intake leak or low fuel pressure.
__________________
'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2012, 03:15 PM   #3
lunerbator
Registered User
2004 KJ Liberty 
 
Join Date: Aug 2009
Location: Maine
Posts: 3
im thinking i have a air leak somewhere
lunerbator is offline   Reply With Quote Quick reply to this message
Unread 08-23-2012, 04:13 PM   #4
streetglideok
Registered User
2005 KJ Liberty 
 
Join Date: Jul 2011
Location: Colorado Springs, Colorado
Posts: 2,452
Doubtful. I would verify you have proper fuel pressure before going further. Once that has been ruled out, there are a couple of areas you need to look at and verify.
streetglideok is offline   Reply With Quote Quick reply to this message
Reply

Tags
check engine light , issues , liberty , o2 sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.