AC vent issue - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 05-28-2014, 01:32 PM Thread Starter
jpmcbride
Registered User
2004 KJ Liberty 
 
Join Date: Jan 2014
Location: Phoenix
Posts: 39
AC vent issue

I have a 2004 KJ with a minor issue. Sometimes the air will blow out the top or bottom, even though I have it set to blow out the front vents. This only happens at fast highway speeds (maybe 70+). It never, or very rarely at least, happens at city speeds.

The only explanation I can come up with is that whatever is used to route the air is vacuum controlled. Since you have less vacuum at high speeds, this could explain what I'm seeing.

Does this thing actually work on vacuum, or can someone explain how it does work? Any tips on troubleshooting would be appreciated.

jpmcbride is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-29-2014, 06:35 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: White River in the Bush, South Africa
Posts: 1,414
Quote:
Originally Posted by jpmcbride View Post
I have a 2004 KJ with a minor issue. Sometimes the air will blow out the top or bottom, even though I have it set to blow out the front vents. This only happens at fast highway speeds (maybe 70+). It never, or very rarely at least, happens at city speeds.

The only explanation I can come up with is that whatever is used to route the air is vacuum controlled. Since you have less vacuum at high speeds, this could explain what I'm seeing.

Does this thing actually work on vacuum, or can someone explain how it does work? Any tips on troubleshooting would be appreciated.

Yes it does work on vacuum, picks up vacuum from the inlet manifold with a small pipe which goes into the cabin to work a complex system under the dash.

Check your vacuum pipe has not got a split in it....you can download the Service Manual for the 2003 KJ here...close enough to your 2004...shows how to get to the vent mechanism: http://www.colorado4wheel.com/manuals/Jeep/KJ

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
post #3 of 3 Old 05-29-2014, 02:49 PM Thread Starter
jpmcbride
Registered User
2004 KJ Liberty 
 
Join Date: Jan 2014
Location: Phoenix
Posts: 39
OK, thanks. I'll check that out.
jpmcbride is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome