ABS and Brake light on? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 04-06-2012, 06:55 AM Thread Starter
idpainpa
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2010
Location: Boise, ID
Posts: 20
ABS and Brake light on?

Just had the ABS light and brake light turn on on my 2005 Jeep Liberty CRD. I am going to run by the local auto parts store and pull any codes. Anyone with a history of similar problems?

idpainpa is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 04-06-2012, 08:03 PM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,387
The local parts store will most likely not be able to pull ABS codes.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is offline  
post #3 of 11 Old 04-07-2012, 06:30 PM Thread Starter
idpainpa
Registered User
2005 KJ Liberty 
 
Join Date: Jun 2010
Location: Boise, ID
Posts: 20
Think I have it figured out. The odometer isn't working either! The differential sensor controls the the odometer and will also through an ABS code if malfunctioning. You were correct, the local auto parts store can't pull it with there machine. Sensor was 20 bucks, we will see if that fixes it.
idpainpa is offline  
post #4 of 11 Old 04-19-2012, 11:53 PM
yardbull
Registered User
2005 KJ Liberty 
 
Join Date: Apr 2012
Location: South Jordan
Posts: 1
I am have the same problem with my 2005 CRD. I ordered the differential sensor, but won't have it for a few days. Please let me know how yours issue comes out and if the sensor fixed the problem or not.
yardbull is offline  
post #5 of 11 Old 10-08-2013, 04:21 PM
2005LibertyCRD
Registered User
 
Join Date: Oct 2013
Location: Davenport
Posts: 1
My 2005 Liberty CRD has the same problem, ABS and parking lights come on and odometer fails intermittently. Please let me know the part number for the sensor at the differential and if replacing works.
2005LibertyCRD is offline  
post #6 of 11 Old 10-09-2013, 01:23 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,326
All of you that are having this problem need to carefully examine the connector and cabling going to the diff sensor to make sure the cable is not fraying onto a nearby part such as the hand-brake cable...a common issue.

There was a TSB issued for the 2005 CRD (I think it was only the CRD!) whereby the factory filled the rear diff with the wrong type of oil. This oil had the nasty habit of chewing up the diff sensor so owners were supposed to take their Jeeps to the dealers to have the rear diff fluid replaced with the correct lubricant and have the sensor replaced.

I will try and find this TSB....it could take me some time!

OK here it is..it is TSB-08-048-05 and appears to include all 2005 models! While you guys were all fast asleep I have been slaving away here on the keyboard!

Here is the link:http://www.jeepkj.com/forum/f212/tsb...-sensor-27665/

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
post #7 of 11 Old 10-16-2013, 10:40 PM
fjsb55
Registered User
2005 KJ Liberty 
 
Join Date: Mar 2011
Location: Bolivar
Posts: 3
Is that sensor something that can be changed without removing the differential cover? I have recently had the diff oil changed and don't want to do it again if I don't have to.
fjsb55 is offline  
post #8 of 11 Old 10-17-2013, 02:53 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,326
Quote:
Originally Posted by fjsb55 View Post
Is that sensor something that can be changed without removing the differential cover? I have recently had the diff oil changed and don't want to do it again if I don't have to.
Yes...no need to remove cover as it sits on top of diff.

Very easy to do!

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
post #9 of 11 Old 10-17-2013, 02:47 PM
fjsb55
Registered User
2005 KJ Liberty 
 
Join Date: Mar 2011
Location: Bolivar
Posts: 3
Thanks Bill! I've been a long time reader/lurker here. It's nice to know there are so many helpful folks who are quick to reply.
fjsb55 is offline  
post #10 of 11 Old 10-20-2013, 11:13 AM
codygspoon
Registered User
 
Join Date: Oct 2013
Posts: 4
I just fixed mine about a month ago. It was the connection to the sensor that broke on mine. But I fixed it and now it work like a champ again. Just in time for the winter months. Had no abs in the rear end. So glad it's fixed.
codygspoon is offline  
post #11 of 11 Old 10-20-2013, 11:30 AM
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 3,004
Quote:
Originally Posted by codygspoon View Post
I just fixed mine about a month ago. It was the connection to the sensor that broke on mine. But I fixed it and now it work like a champ again. Just in time for the winter months. Had no abs in the rear end. So glad it's fixed.
First Post - Welcome to JF -

Good idea to fill out your KJ's profile.

05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded - Sold 2015
95BadBoy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
04 Liberty - Brake light and ABS light came on J-Dawg KJ Liberty Forum 9 03-05-2013 07:43 AM
Brake light on dash oct7brian KJ Liberty Forum 2 02-25-2009 10:04 PM
LED brake light... RipTricket KJ Liberty Forum 3 02-25-2006 10:06 AM
Brake Light kellydeen KJ Liberty Forum 1 09-06-2005 05:40 PM
Brake light change Johnny Walker KJ Liberty Forum 5 05-17-2004 05:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome