5 speed 4x4 trans problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 5 speed 4x4 trans problems

D.i.y. Ford 8.8 tj,xj,yjSavvy Aluminum BumpersSwag Off Road BIG-HIT TJ-YJ Rear Bumper

Reply
Unread 04-01-2014, 01:41 PM   #1
nkennell
Registered User
 
Join Date: Apr 2014
Posts: 3
5 speed 4x4 trans problems

I have an 03' 5 speed. I went in and got the bearings replaced (because I didn't have a press) and a new tie rod. I went in originally because of two sounds. One ended up being a pin on the caliper which they pushed in. Now I only here that when I turn the wheel left. The second sound is definitely coming from the transmission. All they had to say about it was that I should talk to the dealership and see if they have an insulating foam for underneath the shift so you don't hear it in the cab.
I feel like it only does it in the morning when I first start it or when it's cold. But it will do it randomly. Any ideas on what this could be? It still shifts smooth and tight. I don't want my trans going out on me!

nkennell is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.