3.7L Liberty engine developed loud knock - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 02-19-2011, 08:41 PM Thread Starter
Jeffin8tor
Registered User
2002 KJ Liberty 
 
Join Date: Feb 2011
Location: Buxton
Posts: 1
3.7L Liberty engine developed loud knock

Hello, we have a 2002 Liberty with the 3.7L V-6 engine with 178,000 miles that just developed a loud knock in the engine. To me it sounds like it's internal, (possibly a connecting rod bearing?), but wanted to ask if anyone knows of any common things to look for before I get into this too deeply?

Thanks!

Jeff

Jeffin8tor is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 02-21-2011, 08:53 PM
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 3,004
First post - welcome to JF -

Chances are are good that your guess is correct. Not being a heavy mechanic - possibly another member will be able to jump in with a bit more advice.

05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded - Sold 2015
95BadBoy is offline  
post #3 of 11 Old 02-23-2011, 07:15 PM
Liberty&Freedom
Registered User
2003 KJ Liberty 
 
Join Date: Oct 2003
Location: Ohio
Posts: 30
Last winter I had a rocker arm come loose... Made a terrible racket. Turns out this can happen on these jeeps, and it's not a major repair as long as nothing else was damaged. (couple hundred bucks was all for me.)

What could be better than Liberty & Freedom ???......Driving a Jeep that is both?!?!?
2003 Freedom Edition
Liberty&Freedom is offline  
post #4 of 11 Old 12-24-2013, 08:30 PM
raineydoug
Registered User
2003 KK Liberty 
 
Join Date: Dec 2013
Location: waynesboro
Posts: 4
3.7 liter verry bad knock in engine

bought 2003 liberty 3.7l. stopped running withpreviouse owner. checked codes and came up bad crank sensor. removed sensor and entire end was broken off. installed new sensor fired right up but knocks soooo bad sounds like two rod coming out. what could it be?
raineydoug is offline  
post #5 of 11 Old 12-25-2013, 06:12 AM
streetglideok
Registered User
2005 KJ Liberty 
 
Join Date: Jul 2011
Location: Castle Pines
Posts: 3,172
From your description, probably a rod flopping around in the engine, and/or a crank flopping around. The key piece of evidence is the crank sensor. The end was damaged, and that is a dead giveaway to an internal problem with the noise you have.
streetglideok is offline  
post #6 of 11 Old 12-25-2013, 07:48 AM
raineydoug
Registered User
2003 KK Liberty 
 
Join Date: Dec 2013
Location: waynesboro
Posts: 4
Thanks! Sounds like a fun job ahead! Merry Christmas!
raineydoug is offline  
post #7 of 11 Old 12-25-2013, 10:00 AM
TwoBobsKJ
Senior Member
 
TwoBobsKJ's Avatar
2003 KJ Liberty 
 
Join Date: May 2011
Location: Northern
Posts: 774
Here's what a bad rod bearing sounds like when the engine is torn down - I replaced my '03 engine with one from an '07 (after doing some mods to make it work with my Jeep's computer) and when I pulled my original this is what I found. It's the #6 cylinder:



Here's an overview of the engine swap.

Bob

2003 Renegade, Black
- 3.7L, 42RLE, 4.10's, ARB Bull Bar, Smittybilt XRC 9500lb Winch, 4X Guard Trans skid, Skid Row Engine skid, Factory T-case & Tank skids, Custom BoulderBars, JBA Front Coilovers, OME 948 rear springs, Bilstein rear shocks, JBA A-Arms, Moabs with Goodyear Duratracs 265/70-16
TwoBobsKJ is offline  
post #8 of 11 Old 12-25-2013, 04:59 PM
raineydoug
Registered User
2003 KK Liberty 
 
Join Date: Dec 2013
Location: waynesboro
Posts: 4
thanks Bob! You really gave a lot of useful information! how hard was that engine to get out? lucks like a lot of work at first glance.
raineydoug is offline  
post #9 of 11 Old 07-08-2015, 08:49 PM
Mcushman
Registered User
 
Join Date: Jul 2015
Location: Pecos
Posts: 2
I have a 2003 Jeep Liberty it started making a knocking noise and the machine at autozone throws a code of it being the spark plugs if the spark plugs were bad and misfiring would it knock? TIA
Mcushman is offline  
post #10 of 11 Old 07-08-2015, 09:25 PM
Mcushman
Registered User
 
Join Date: Jul 2015
Location: Pecos
Posts: 2
I have a 2003 Jeep Liberty it started making a knocking noise and the machine at autozone throws a code of it being the spark plugs if the spark plugs were bad and misfiring would it knock? TIA
Mcushman is offline  
post #11 of 11 Old 07-08-2015, 09:34 PM
pentastarguy
Web Wheeler
2015 JK Wrangler 
 
Join Date: Dec 2011
Location: sussex
Posts: 12,064
i would just put in new plugs and go from there.
pentastarguy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
'02 Liberty - loud snap from front end WO312 KJ Liberty Forum 5 06-26-2009 12:32 PM
02 Liberty LTD Knock When Accelerating MKaye02 KJ Liberty Forum 1 06-12-2009 03:31 AM
'02 liberty mechanical fan is loud Strorg KJ Liberty Forum 4 10-27-2008 06:58 PM
loud knock in engine sammiejoedee KJ Liberty Forum 2 01-20-2008 08:29 PM
is the FUEL PUMP on your liberty LOUD ??? soimcrazy KJ Liberty Forum 2 03-23-2005 02:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome