2005 Liberty Power Locks Not Working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 08-03-2011, 12:37 PM Thread Starter
coorsman
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Nebo
Posts: 5
2005 Liberty Power Locks Not Working

I have a 2005 Liberty with the 3.7 motor. Sunday, my wife went to the store and the radio, power locks, and interior lights all quit working. Locks will not even unlock with the remote. Also, when switch is turned on, all gauge needles go all the way to the right and then back to the left. I have no error codes and have put in two different batteries as well as changed battery cables. I am at a loss here and need some help.

coorsman is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 08-03-2011, 12:40 PM
HustlinFlip
Registered User
2004 KJ Liberty 
 
Join Date: May 2009
Location: MD
Posts: 136
Sounds like a fuse is bad...

Maybe this will help:



HustlinFlip is offline  
post #3 of 11 Old 08-03-2011, 01:05 PM Thread Starter
coorsman
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Nebo
Posts: 5
Have checked every fuse inside and out and all are fine.
coorsman is offline  
post #4 of 11 Old 08-03-2011, 02:09 PM
HustlinFlip
Registered User
2004 KJ Liberty 
 
Join Date: May 2009
Location: MD
Posts: 136
Did you check the firewall fuses/relays under the hood?
HustlinFlip is offline  
post #5 of 11 Old 08-03-2011, 03:06 PM Thread Starter
coorsman
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Nebo
Posts: 5
Yes. All those are fine as well. Weird thing is that after I start the engine, the locks will start working, but the interior lights and radio still will not.
coorsman is offline  
post #6 of 11 Old 08-03-2011, 04:11 PM
HustlinFlip
Registered User
2004 KJ Liberty 
 
Join Date: May 2009
Location: MD
Posts: 136
Damn... I'm stumped

Maybe someone else can chime in here...
HustlinFlip is offline  
post #7 of 11 Old 08-04-2011, 06:15 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, South Africa
Posts: 1,282
Possibly the BCM is faulty....all those functions are controlled there.
I would take out the BCM and check all contacts and components are firmly plugged in.
Billwill is offline  
post #8 of 11 Old 08-04-2011, 11:42 AM Thread Starter
coorsman
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Nebo
Posts: 5
The BCM is looking more and more like the problem. I am going to take it out and see if all connections are good. Check the local Dodge place and a new one is $300 and another $200 for labor.

Anyone have a pic or diagram on it's location. One dealer is telling me it is on the passenger side dash and another one telling me it is in the driver's side dash.

Last edited by coorsman; 08-04-2011 at 11:55 AM.
coorsman is offline  
post #9 of 11 Old 08-04-2011, 02:12 PM
HustlinFlip
Registered User
2004 KJ Liberty 
 
Join Date: May 2009
Location: MD
Posts: 136
HustlinFlip is offline  
post #10 of 11 Old 08-04-2011, 04:10 PM Thread Starter
coorsman
Registered User
2005 KJ Liberty 
 
Join Date: Aug 2011
Location: Nebo
Posts: 5
Thanks for the image. Going to try and take it out tomorrow and replace it to see if that is the fix. Thanks for all the help.
coorsman is offline  
post #11 of 11 Old 06-11-2013, 10:19 PM
ronaldfdr
Registered User
2004 KK Liberty 
 
Join Date: Jun 2013
Location: pompano beach
Posts: 1
did you find out the solution for your problem?

I'm having the same problem with my jeep... please let me know how you fixed yours... thank you
ronaldfdr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2005 liberty cigarette lighter: no power lowbot KJ Liberty Forum 1 05-22-2009 12:51 PM
2002 Liberty Power Locks Sound grabick_luca KJ Liberty Forum 5 01-29-2007 08:16 AM
Power Locks 03 Liberty Sport ZodiacMan KJ Liberty Forum 3 01-22-2007 09:13 PM
Wheel locks for 2005 Liberty Mlots KJ Liberty Forum 6 05-14-2005 07:29 PM
2005 Liberty - Disabling auto door locks EsoxRoss KJ Liberty Forum 3 04-12-2005 05:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome