2005 Jeep Libety Low Beams Don't Work - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 2005 Jeep Libety Low Beams Don't Work

Engo LED Flush Mount Lights *PAIR* Flood or Spot 1,600 LumYukon Ultimate 35 axle kit for c/clip axles with Yukon ZipRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 10-16-2014, 08:07 PM   #1
Smokey4402
Registered User
 
Join Date: Oct 2014
Posts: 2
2005 Jeep Libety Low Beams Don't Work

Low beams don't work at all. High beams are good. Already swapped out the low beam relay, fuses, and switch assembly on steering column. Any ideas?

Smokey4402 is offline   Reply With Quote Quick reply to this message
Unread 10-17-2014, 01:03 AM   #2
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 1,008
Quote:
Originally Posted by Smokey4402 View Post
Low beams don't work at all. High beams are good. Already swapped out the low beam relay, fuses, and switch assembly on steering column. Any ideas?
Have you checked the Bulbs are OK and the socket contacts are good and clean?

You sure you identified the Low Beam relay correctly...on the rear of the Junction Block.....small relay by itself on the lower rear of the block?

If you remove the Low Beam Relay and briefly jumper pins 30 and 87 together inside the relay socket then the this will test the wiring run from the Low Beam Relay all the way to the lamps....the low beam lamps should light unless the bulbs are blown or there is a bad contact somewhere.

If this does work only with this jumper in place then the BCM may have a problem as it controls the grounding of the Low Beam Relay coil.
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote Quick reply to this message
Unread 10-22-2014, 04:42 PM   #3
richm20
Registered User
2006 KJ Liberty 
 
Join Date: Jan 2010
Location: Long Island
Posts: 128
Check the "bulbs" although both going at the same time is rare.... You may have only noticed once the 2nd went out....
richm20 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.