2002 Liberty 3.7 No Oil Pressure - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 03-09-2008, 08:27 PM Thread Starter
Registered User
Join Date: Mar 2008
Location: Columbus, MS
Posts: 1
2002 Liberty 3.7 No Oil Pressure

I am an Automotive Instructor at a High School Vocational Center and my class recently swapped an engine in a 2002 Liberty with the 3.7 engine. We installed a remanufactured long block and the engine will not build oil pressure. I will be the first to admit that my experience with Jeep products are very limited and I am not familiar with the internal workings of this particular engine. I do know the engine was installed correctly and the oil pickup is in correct. We followed the recommended procedure for start-up but it never gets oil pressure. Can anyone shed light on this? I have thought of the pressure relief valve, but I hope that is not the problem.

BennyC is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
My New - Used 2002 Liberty 97TJ2.5 KJ Liberty Forum 6 07-09-2009 11:46 PM
2002 Liberty, should I get it? ObiHann KJ Liberty Forum 38 06-07-2008 05:39 AM
2002 Liberty tommy2 KJ Liberty Forum 0 05-26-2007 03:30 PM
2002 liberty shawl KJ Liberty Forum 2 10-30-2005 08:48 PM
2002 Liberty 245-75-16 (Fit???) beagle3 KJ Liberty Forum 5 07-17-2005 09:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome