08 liberty rear hatch problem - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 03-11-2008, 04:11 PM Thread Starter
aquaholic_
Registered User
 
Join Date: Jan 2008
Location: pittsburgh
Posts: 49
08 liberty rear hatch problem

anyone having problems with their rear hatch switches telling the bcm that it is continually ajar? jeep dealer says this a known problem and they have a fix but i'm just wondering if they are blowing smoke up my a%*. anyone know if there is a tsb out on this?


97 xj cherokee se, 4.0L, AW4
bad azz classic white 74 A3 corvette
retina burning red 99 A4 corvette
2500 summit white 02 avalanche 8.1L A4
voodoo blue 07 toyota fj cruiser
92 pearl white custom hd fatboy
aquaholic_ is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-11-2008, 08:04 PM
LibertyWrangler
Registered User
 
Join Date: Mar 2008
Location: Beloit, WI
Posts: 56
I have an 06 renegade and sometimes even if I hit the unlock button on either the key fab or the jeep itself it sometimes doesn't unlock. Quirky thing!
LibertyWrangler is offline  
post #3 of 6 Old 03-12-2008, 06:39 AM
KUHawkhead
Registered User
2008 KK Liberty 
 
Join Date: Feb 2008
Location: McPherson Kansas
Posts: 122
My 08 Liberty has not experiencd this. I have noticed, however, when using the remote to unlatch the back window, that I sometimes have to close it 2-3 times to get it to latch. I just think the cylinders that hold it up are still stiff, and holding it open longer.
KUHawkhead is offline  
 
post #4 of 6 Old 03-12-2008, 12:42 PM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
Hi
This is a known issue http://www.wkjeeps.com/tsb/tsb_wk_0802207.pdf
Regards,
Merlin

UK Chrysler Jeep Master Tec.
merlinTec is offline  
post #5 of 6 Old 03-13-2008, 05:43 PM Thread Starter
aquaholic_
Registered User
 
Join Date: Jan 2008
Location: pittsburgh
Posts: 49
thanks merlin. i don't know why the lunkheads at my dealership dont access this info. they have ordered new latches for me and told me that is the fix although i knew it would be some way more simple. i handed them the tsb number the last time it was in but i didn't have the entire tsb so they just ignored it. maybe if i shove this one down his throat he'll read it.

97 xj cherokee se, 4.0L, AW4
bad azz classic white 74 A3 corvette
retina burning red 99 A4 corvette
2500 summit white 02 avalanche 8.1L A4
voodoo blue 07 toyota fj cruiser
92 pearl white custom hd fatboy
aquaholic_ is offline  
post #6 of 6 Old 03-13-2008, 06:09 PM
Busch2fan
Registered User
2008 KK Liberty 
 
Join Date: Mar 2008
Location: Temperance, mi
Posts: 187
No problems with my '08 Liberty so far. Had it since Oct.
I'm going to Bristol tomorrow with my buddy who works in assembly at Jeep in Toledo. I'll ask him if there are
reported problems. He can look that stuff up.
He always seems to be aware of issues.
He is a team leader and is appraised of problems.

Mar 24th, my buddy indicated there has been no discussion at the Jeep assembly about this problem that he is aware of. But I see someone has identified a tech bulletin.

Last edited by Busch2fan; 03-24-2008 at 06:16 PM.
Busch2fan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
02 Liberty rear hatch problem thezman KJ Liberty Forum 0 11-09-2008 01:07 PM
07 Jeep Liberty rear power outlet problem zogger KJ Liberty Forum 6 08-25-2008 03:14 PM
Rear wiper problem 03 liberty? apik1 KJ Liberty Forum 1 03-09-2008 04:45 AM
Rear hatch lock? yikess KJ Liberty Forum 10 04-28-2004 02:13 PM
Rear Hatch opens on 2004 liberty jcbizzle KJ Liberty Forum 2 03-18-2004 11:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome