post #1 of Old 10-29-2009, 06:33 PM Thread Starter
ramack333
Registered User
 
Join Date: Oct 2009
Location: ok
Posts: 1
07 rear wheel sensor

Hello I have a 2007 Liberty 4WD with 24k miles.

My ABS, ESP, and traction control light goes on. I feel some type of odd pulsation when I hit the breaks and the problem gradually gets worse.

Took it to my mechanic and he replaced the right rear wheel sensor week later problem happned again. Got the same sensor replaced 2 more times same problem still. Every time I took the liberty to my mechanic their computer shows the sensor as the problem. And my mechanic only charged me for the first fix

Ive searched the forums and saw a few similar problems but none with a solution.

I would appreciate any advice.
Thanks!

ramack333 is offline  
post #2 of Old 10-29-2009, 09:09 PM
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
Maybe a reflash of your ABS module might work.For some reason your Computer is not reconizing that sensor.
richd is offline  
post #3 of Old 10-30-2009, 02:34 AM
merlinTec
Registered User
 
merlinTec's Avatar
 
Join Date: Jul 2007
Location: England
Posts: 2,944
More like a wiring fault.

UK Chrysler Jeep Master Tec.
merlinTec is offline  
post #4 of Old 06-13-2013, 12:40 AM
redncfootball
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Posts: 55
Did you ever find a fix for this? I am going through the same problem. Some help would be appriciated
redncfootball is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Noise from around the rear right wheel Sinphar KJ Liberty Forum 5 10-12-2009 12:49 PM
p0161 O2 Sensor Heater Circuit (Bank 2 Sensor 2) DaniLaurette KJ Liberty Forum 1 01-19-2009 03:04 PM
Hit on rear right wheel, OUCH! matr8er KJ Liberty Forum 23 03-23-2007 04:24 PM
TSB 08-048-05 Differential Mounted Rear Wheel Speed Sensor oldnavy KJ Liberty Forum 5 11-22-2005 03:33 PM
Rear Wheel Vibration When Wheel Cranked . . . Cougar Guy KJ Liberty Forum 8 02-22-2005 12:44 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome