JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KJ Liberty Forum (http://www.jeepforum.com/forum/f28/)
-   -   06 libby CRD won't crank (http://www.jeepforum.com/forum/f28/06-libby-crd-wont-crank-1554296/)

Pete M 07-27-2013 11:31 AM

06 libby CRD won't crank
 
It did this a couple years ago and that time it turned out to be the little bar that goes inside the ignition switch was broken. so we started there this time. got it all apart and the little bar is still fine. tried turning the ignition switch manually and the Jeep cranked and fired! but then died a second or so later. tried again with the same result but the jeep died even quicker. a third attempt brought the same result and then nothing. no more cranking at all. So I figured it was a faulty ignition switch. replaced that today and still nothing. doesn't even try to crank. is there something else in the steering column I'm missing?

95BadBoy 07-27-2013 06:13 PM

Pete

Are you getting full voltage at the starter? Yah, you probably already checked all ends of the cables - thought I'd throw it out there anyhoo. Have you had any transponder keys made recently? How old is the battery?

Billwill 07-28-2013 02:56 AM

Quote:

Originally Posted by Pete M (Post 15724605)
It did this a couple years ago and that time it turned out to be the little bar that goes inside the ignition switch was broken. so we started there this time. got it all apart and the little bar is still fine. tried turning the ignition switch manually and the Jeep cranked and fired! but then died a second or so later. tried again with the same result but the jeep died even quicker. a third attempt brought the same result and then nothing. no more cranking at all. So I figured it was a faulty ignition switch. replaced that today and still nothing. doesn't even try to crank. is there something else in the steering column I'm missing?


If you have the SKIS system installed you must have the chipped key in the ignition while turning the ignition key with a screwdriver.;)

If you do have SKIS, the amber key light with a line through it should come on for a few seconds when turning ignition ON.

If it flashes at you....it is not happy with the chip in the key.
If it stays on all the time likewise you have a SKIS problem.


The time now is 10:55 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.