06 libby CRD won't crank - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 07-27-2013, 11:31 AM Thread Starter
Pete M
Registered User
1988 MJ Comanche 
 
Join Date: Sep 2005
Location: S/E Michigan
Posts: 1,837
06 libby CRD won't crank

It did this a couple years ago and that time it turned out to be the little bar that goes inside the ignition switch was broken. so we started there this time. got it all apart and the little bar is still fine. tried turning the ignition switch manually and the Jeep cranked and fired! but then died a second or so later. tried again with the same result but the jeep died even quicker. a third attempt brought the same result and then nothing. no more cranking at all. So I figured it was a faulty ignition switch. replaced that today and still nothing. doesn't even try to crank. is there something else in the steering column I'm missing?


-88 MJ; 4.0L, ex-2wd, TJ ax15/231, 78 Ford D44 w/spool, 9" w/posi, 33" trXus MTs, custom roll-bar/bumpers/etc.
Also an 86 MJ Metric ton and 2 '90 MJs
Projects/wheelin' pics: picturetrail.com/petermontie
My email: petermontie@hotmail.com
ComancheClub.com/forums
Pete M is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-27-2013, 06:13 PM
95BadBoy
Moderator
2005 TJ Wrangler 
 
Join Date: May 2006
Location: Grand Forks, ND
Posts: 3,001
Pete

Are you getting full voltage at the starter? Yah, you probably already checked all ends of the cables - thought I'd throw it out there anyhoo. Have you had any transponder keys made recently? How old is the battery?

05 TJ RME 42RLE with some things
05 KJ CRD 545RFE, GDE Eco tune, Franky II, Al's 4.5 A-arms, JK Rubi Moabs, Silent Armors 245-70-17's, Spidertrax Adapters, Rola Basket, Fumoto Valve, Pinch welds pounded - Sold 2015
95BadBoy is offline  
post #3 of 3 Old 07-28-2013, 02:56 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,311
Quote:
Originally Posted by Pete M View Post
It did this a couple years ago and that time it turned out to be the little bar that goes inside the ignition switch was broken. so we started there this time. got it all apart and the little bar is still fine. tried turning the ignition switch manually and the Jeep cranked and fired! but then died a second or so later. tried again with the same result but the jeep died even quicker. a third attempt brought the same result and then nothing. no more cranking at all. So I figured it was a faulty ignition switch. replaced that today and still nothing. doesn't even try to crank. is there something else in the steering column I'm missing?

If you have the SKIS system installed you must have the chipped key in the ignition while turning the ignition key with a screwdriver.

If you do have SKIS, the amber key light with a line through it should come on for a few seconds when turning ignition ON.

If it flashes at you....it is not happy with the chip in the key.
If it stays on all the time likewise you have a SKIS problem.

2002 2.5 Export CRD Manual 5 speed.
Billwill is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome