'04 Rear End Vibration/Chatter - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > '04 Rear End Vibration/Chatter

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineRubicon Express Suspensions from CCOR 706-207-4140Smittybilt Hard Tops @ Oconee Off-Road! 706-534-9955

Reply
Unread 03-09-2008, 06:03 PM   #1
janschutz
Registered User
2004 KJ Liberty 
 
Join Date: May 2007
Location: PA
Posts: 4
'04 Rear End Vibration/Chatter

Hello,

Recently, I noticed my 2004 Liberty Ltd has developed a completely random vibration/chatter in the rear end.

I would describe the feeling as the same as if my rear tires were running over rumble strips - like the kind that are sometime cut into the shoulders/median of a road to keep drivers from drifting off the roadway.

The vibration seems to happen right around the 45 MPH mark and in the low RPM range, so I don't know if it's a tranny problem or a tire problem.

Any help would be appreciated.

Oh - for what it's worth - the Jeep has about 44,500 miles.

Thanks.

janschutz is offline   Reply With Quote
Unread 03-10-2008, 06:25 PM   #2
janschutz
Registered User
2004 KJ Liberty 
 
Join Date: May 2007
Location: PA
Posts: 4
Did some "testing" today and the vibration/chatter occurs when the RPMs drop to about 1500 during a gear change. I turned the O/D off and, of course, RPMs stay around 2000 and, so far, there is no sign of the problem.

Seems to only be prevalent when O/D is on, I'm doing about 45 MPH and the RPMs are at 1500.
janschutz is offline   Reply With Quote
Unread 03-13-2008, 10:14 AM   #3
Bobcat
Registered User
 
Join Date: Sep 2005
Posts: 27
U-Joint?

Had the same thing happen yesterday... vibration at ~45 and ~15 mph... took it in today and had rear u-joint replaced... seal at that point needed replaced as well. Drives smooooth now!
Bobcat is offline   Reply With Quote
Unread 03-17-2008, 03:01 AM   #4
wbrewski
Registered User
 
Join Date: Nov 2007
Location: Santa Ana Ca.
Posts: 6
I have had the same problem on my 2003. I have had the trans. gone throught and it cured 90% of the problem,but thy told me that my dif. is a limited slip and it needs an additive ( mopar friction modifier additive) this is going to be my next step. I am going to rempve thew cover drain the oil oil and refill it and add the additive.
wbrewski is offline   Reply With Quote
Unread 03-18-2008, 02:38 PM   #5
daxiet
Registered User
 
Join Date: Nov 2007
Location: Rustenburg, RSA
Posts: 76
Check the U-joints or Driveshaft balance.

They present at speed not RPM. Considering engine RPM and Gearbox deterimine Driveshaft speed. In 3rd you could be doing 3500 rpm and in 4th it will drop to 2000rpm yet driveshaft speed remains the same.
daxiet is offline   Reply With Quote
Unread 03-18-2008, 08:04 PM   #6
janschutz
Registered User
2004 KJ Liberty 
 
Join Date: May 2007
Location: PA
Posts: 4
Thanks all:

I have to get 'er in for a recall anyway. I don't suppose a U-joint - if that is the problem - would fall under the powertrain warranty?

In my experience, my local stealership does anything/everything to get out of warranty service.
janschutz is offline   Reply With Quote
Unread 03-19-2008, 05:19 AM   #7
sonix
Registered User
 
Join Date: Mar 2008
Location: Pretoria, South Africa
Posts: 1
Lo everyone! ... still new here, but I see everyone is talking about this "vibration" they get on the Liberty ....
I've got a 2003 Liberty CRD, and also get a vibration, but it sounds like it's something TOTALLY different? ...
In my case, the vibration can only be heard from 2000-2250RPM ...regardless of what speed I'm driving ... the sound also comes from the back, but it sounds like the exhaust is vibrating against the body ...
When the car is stationary, and revving up to 2100RPM, then there is no sign of the vibration ... I also had a look at the exhaust, and can NOT find any place, where it might "rattle" against the body ..
Maybe the "vibration" just sound different here in South Africa ?
sonix is offline   Reply With Quote
Unread 12-07-2013, 08:53 AM   #8
Johndeerefan
Registered User
 
Join Date: Dec 2013
Posts: 7
What was the fix for the OPs problem? My 05 limited does the exact same thing, rumble strip feel. Checked the u joints and they are fine. Only does it in overdrive at low rpm. Take out of od and it goes away.
Johndeerefan is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.