04 Liberty tail light problems - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 04-19-2010, 03:24 PM Thread Starter
Adroc3905
Registered User
 
Join Date: Apr 2010
Location: Rochester
Posts: 2
04 Liberty tail light problems

Hi everyone,

I have searched the forum but was unable to find my answer so now I am posting it. I appreciate any and all help.

I recently (last fall) installed an aftermarket trailer hitch wiring harness that uses a piggy back type system from the left and right rear factory harnesses. It worked flawless until now.
Last week the Jeep left turn signal indicator inside the cluster would illuminate when I applied the brakes and the left brake and middle brake lights would flash when I used the left signal. I immediately assumed it was a crossed ground wire between the signal and brake lights at the harness so I unplugged the aftermarket trailer hitch piggy back system and reinstalled the factory harness as a temp fix. Now the driver’s front and rear parking lights do not illuminate at all but the cluster illumination when applying brakes and flashing during signal operation has stopped. The rear bulb is fine (although now that I think about it the front one has yet to be checked) as I tested it to be sure. Also the turn signal, brake and reverse work perfect. It’s simply the parking light feature for the entire driver’s side that is not operating now.

Rather than trace a chaffed or broken wire through thru numerous feet of Jeep I was hoping that maybe someone could recommend some other options I can exhaust first. I also checked the fuse box inside the Jeep. Here is the weird part. The 2004 owner’s manual states that fuse location #23 is the left parking light fuse. I immediately though awesome….easy fix. Well in my Jeep fuse location #23 is empty. There is not even prongs to accept a fuse into this location. So now I am baffled. Are there fuses under the hood that may be worth looking at? Anyone else have this problem?

Thanks

Adroc3905 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-21-2010, 09:12 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,356
There is a Sticky above called Liberty Service manual.
Download section 8, circuit diagrams (about 40 meg)
This is for the 2002 models,gas or diesel,local or export, LHD...RHD etc. but I think the basic wiring and harnesses will not have changed much for the later models.
It is in PDF format, keep it on your PC and print the pages you think are relevant...I find this extremely usefull!
Billwill is offline  
post #3 of 5 Old 04-21-2010, 04:07 PM
T-birdJunkie
Registered User
2002 KJ Liberty 
 
Join Date: Aug 2009
Location: Mason, Ohio
Posts: 1,113
This is directly caused by a trailer harness issue. Same happened to ThunderbirdJunkie's. He simply removed the harness.
T-birdJunkie is offline  
post #4 of 5 Old 05-03-2010, 04:20 PM Thread Starter
Adroc3905
Registered User
 
Join Date: Apr 2010
Location: Rochester
Posts: 2
Removed harness completely, similar issue. Its not the harness causing this.
Adroc3905 is offline  
post #5 of 5 Old 05-05-2010, 05:09 AM
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: Hoedspruit, in the Bush, South Africa
Posts: 1,356
As I said two posts above, download the circuit diagram and use it or get someone with some electrical knowledge to use it to trace the problem.
Billwill is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Liberty 05 Tail light trailer wiring. drozenski KJ Liberty Forum 1 08-01-2009 04:25 PM
liberty tail light assembly...need help jvk06tj KJ Liberty Forum 3 05-12-2009 03:28 PM
tail light question (liberty 05 renegade) maximebeauvais KJ Liberty Forum 6 03-17-2009 05:40 PM
03 liberty Renegade Dash ligh/Right tail light morhaven KJ Liberty Forum 2 06-10-2008 12:23 PM
2008 Liberty tail light wiring Justjoe444 KJ Liberty Forum 1 05-24-2008 09:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome