JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   KJ Liberty Forum (http://www.jeepforum.com/forum/f28/)
-   -   '04 Liberty Rad Fan only low speed (http://www.jeepforum.com/forum/f28/04-liberty-rad-fan-only-low-speed-1547616/)

MACJeepDad 07-11-2013 03:14 AM

'04 Liberty Rad Fan only low speed
 
Okay, so I've narrowed down the reason for my Jeep overheating to the electric radiator fan. It stays on 'low' setting, and will not speed up when it's supposed to. I swapped relays, so it's not that, and I've already had to replace the radiator due to a crack in the plastic casing, and will probably have to look into a new head gasket now...

But I want to know, is there an EXTREMELY inexpensive way to DIY the fan speed issue? Some fancy wiring trick or anything like that that anyone knows about? This is my family's only car, and we live in AZ, where it was 113 degrees today, and I'd LOVE to be able to use the AC again.

Thank you!!!

tjkj2002 07-11-2013 08:44 AM

Does the fan have 2 or 3 wires?

Billwill 07-12-2013 01:45 AM

What tjkj2002 said^^^.

If there are only two wires to the fan then it is single speed fan
Three wires and it uses a high speed relay and a low speed relay.:)

MACJeepDad 07-13-2013 04:38 AM

3 wires - both high and low relays - I've tried swapping them, even with other identical relays, but this has made no difference.

Billwill 07-13-2013 07:20 AM

Quote:

Originally Posted by MACJeepDad (Post 15671702)
3 wires - both high and low relays - I've tried swapping them, even with other identical relays, but this has made no difference.

Try jumpering out pins 30 and 87 in the relay sockets and see what happens...fan should run at different speeds unless there is a wiring problem to the fan or the fan is burnt out on the high speed side.:confused:

MACJeepDad 07-14-2013 03:41 AM

Billwill, forgive my ignorance, but how would I do this?

Billwill 07-15-2013 01:36 AM

1 Attachment(s)
Quote:

Originally Posted by MACJeepDad (Post 15674521)
Billwill, forgive my ignorance, but how would I do this?


Here is a picture from the CRD engine but I believe it is similar to your model KJ.

You see that there is a "relay radiator fan high" and a"relay.....low" in the PDC under the hood.

If you pull out the relays one at a time and flip them over you will see how the pins are labeled...make a note of where pins 30 and 87 are located.

Now with the relay still removed, take a short section of wire ( a paper clip will do) and carefully push this into the corresponding 30 and 87 female slots in the exposed relay socket.

With ignition ON the fan should run first at low speed and then at high speed. If not then you need to trace the wiring going from the pin 87 slot all the way to the connector on the fan (both sides of the connector actually) to see if the voltage has gone missing somewhere....you need a Multimeter set to DC volts for this exercise!

The circuit diagram shows one wire being Dark Green/Dark Blue for the High speed and Dark Blue/ Dark Green for the Low speed wire....the first color is the predominate color of the wire, the second color is the stripe that runs along the wire.

Note that your wire colors may be different to what my "Diesel" circuit diagram shows but the theory stays the same.

MACJeepDad 07-19-2013 11:45 PM

Thank you so much for this!!! Unfortunately, I tried the paper clip thing, but now neither fan speed works... I think my fan is kaput, but I'm going to test it tomorrow. Is it okay to splice the wires and connect straight to the battery poles, or is that too much power? I've heard about using a 12v battery, but I don't have one...

Thanks again. I owe you one for all your help.

Billwill 07-20-2013 01:34 AM

Quote:

Originally Posted by MACJeepDad (Post 15697544)
Thank you so much for this!!! Unfortunately, I tried the paper clip thing, but now neither fan speed works... I think my fan is kaput, but I'm going to test it tomorrow. Is it okay to splice the wires and connect straight to the battery poles, or is that too much power? I've heard about using a 12v battery, but I don't have one...

Thanks again. I owe you one for all your help.


Check all your fuses...you probably blew one.

Safest thing is to disconnect the fan and connect it direct to the battery with a fuse inline...about 15 A should do. Ground the Black wire and touch first the Low speed wire to the battery positive to see if it turns slowly then move the lead to the High Speed side and see if it runs at high speed.

If the fan does not turn or blows the fuse then it is fried.:(

MACJeepDad 07-22-2013 06:44 PM

Oh dear, the fan is fried...

streetglideok 07-22-2013 07:18 PM

A tool that every single one of you, who wish to try and figure things out on your own should have, is a digital volt/ohm meter. They are inexpensive, or some are at least, and its a must have for any electrical work. 2 minutes with one, and you would already know your fan motor was cooked. Now how much would that ability to figure that out be worth? Much more than the cost of the meter. This isn't an attack, or a slam, this is just common sense advice to everyone on this board. It makes life a lot easier to figure things out, and when you're asking for help, all any of us have to do is tell you to measure this or that, and give you an answer. Even our oil change guys have decent meters in the shop. If you don't have one, get one. If you don't know how to use it, ask!

tjkj2002 07-22-2013 07:33 PM

Quote:

Originally Posted by streetglideok (Post 15706961)
A tool that every single one of you, who wish to try and figure things out on your own should have, is a digital volt/ohm meter. They are inexpensive, or some are at least, and its a must have for any electrical work. 2 minutes with one, and you would already know your fan motor was cooked. Now how much would that ability to figure that out be worth? Much more than the cost of the meter. This isn't an attack, or a slam, this is just common sense advice to everyone on this board. It makes life a lot easier to figure things out, and when you're asking for help, all any of us have to do is tell you to measure this or that, and give you an answer. Even our oil change guys have decent meters in the shop. If you don't have one, get one. If you don't know how to use it, ask!

X2.............

Even better yet a PowerProbe.Resisted getting one for so long now I don't know what I'd do without it.

streetglideok 07-22-2013 09:45 PM

That's what some say, but personally never cared for them. It may be the class of mechanics I've seen use them, tending to be hacks that murdered connectors with them, and not so much the tool itself. Vantage pro, amp probes, and two test lights do 99% of my stuff. The one test light is a hd tester, an old halogen sealed beam for loading heavier circuits that are harder to check for voltage drops.

streetglideok 07-22-2013 09:49 PM

Depending on what you want to spend, you can go to harbor freight and spend a little, or find a place that sells Fluke meters, that a lot of professionals use. I've had the same fluke meter for the last 15 years, I cant tell you how much money that little meter has earned me.

Billwill 07-23-2013 03:03 AM

I have my Fluke Multimeter in my Jeep at all times together with my 7 inch Samsung Galaxy Tablet with all the circuit diagrams/OBDII codes etc. on them...plus some spare wiring etc. in case I have a breakdown far from home.

I have fixed about 6 wiring problems on my 2002 CRD and would have had no chance to do that without the multimeter.

The Fluke is actually more accurate than needed for general usage on the Jeep though...any reasonable "made in China" brand would do as absolute accuracy is not needed so I fully agree with the comments here about using a Multimeter.....I was able to keep my Fluke...and tools...as a retirement gift after 34 years in the Mainframe Computer Hardware Support arena;)


The time now is 06:39 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.