03to04 motor swap help - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 03to04 motor swap help

The Original 3/8" Ruffstuff Diff Cover!Safety Thimble FairleadsEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 06-01-2014, 03:06 AM   #1
wvjeepman2014
Registered User
 
Join Date: May 2014
Location: princeton, wv
Posts: 20
03to04 motor swap help

i have a 2004 jeep liberty 3.7 i put a 03 model engine in it swapped the refluctor rings out and dropped it in hit the key fired right up the jeep will not take gas u try to throttle it it just bogs out well i checked all the coils put new plugs i put 3 new injectors in on pass side and now i noticed the 03 model injectors show diff from the 04 injectors would that cause it to not take fuel?crank censor cam censor and knock censor are all the same everything plugged up fine?can someone please help me please please please

wvjeepman2014 is offline   Reply With Quote Quick reply to this message
Unread 06-02-2014, 09:13 PM   #2
TwoBobsKJ
Senior Member
2003 KJ Liberty 
 
Join Date: May 2011
Location: Northern, OH
Posts: 595
Did you also swap out the cam tone ring on the right side cam? The cam ring is different from '04 to '03 just as the reluctor ring is.

If the cam ring is not the correct one the computer won't feed the spark and fuel to the proper cylinder at the proper time

Bob

Sent from my iPhone using JeepForum
__________________
2003 Renegade, Black
- 3.7L, 42RLE, 4.10's, 4X Guard Trans skid, Factory Engine, T-case, Tank skids, Modded BoulderBars sliders, OME 927/948, Bilsteins, JBA A-Arms & 1/4" top plate, 1 extra rear iso/side, Moabs with Firestone Destination AT's 255/70-16
TwoBobsKJ is offline   Reply With Quote Quick reply to this message
Unread 06-03-2014, 05:58 AM   #3
wvjeepman2014
Registered User
 
Join Date: May 2014
Location: princeton, wv
Posts: 20
the tone ring as in the lil round ring behind the cam gear its self?
wvjeepman2014 is offline   Reply With Quote Quick reply to this message
Unread 06-04-2014, 11:03 AM   #4
TwoBobsKJ
Senior Member
2003 KJ Liberty 
 
Join Date: May 2011
Location: Northern, OH
Posts: 595
Quote:
Originally Posted by wvjeepman2014
the tone ring as in the lil round ring behind the cam gear its self?
The gear and ring are a single unit - so you replace the right side cam gear with one for your model year (can be from ANY model Chrysler product with a 3.7 from the same year as your original) or you can get one from engine-guru.com. Go to their website to get their number to call about getting the cam gear. I bought their kit that includes the reluctor gear, the cam gear and the EGR blocking plate when I swapped in a 3.7 from an '07 Dodge Dakota into my '03 Libby. The kit worked great and kept me from having to break down two engines just to get the reluctor and cam gears out of my original engine.

Hope this helps!

Bob

Sent from my iPhone using JeepForum
__________________
2003 Renegade, Black
- 3.7L, 42RLE, 4.10's, 4X Guard Trans skid, Factory Engine, T-case, Tank skids, Modded BoulderBars sliders, OME 927/948, Bilsteins, JBA A-Arms & 1/4" top plate, 1 extra rear iso/side, Moabs with Firestone Destination AT's 255/70-16
TwoBobsKJ is offline   Reply With Quote Quick reply to this message
Unread 06-04-2014, 04:00 PM   #5
wvjeepman2014
Registered User
 
Join Date: May 2014
Location: princeton, wv
Posts: 20
i swapped out the ring on the cam gear its a lil wheel with little like windows in it and i swapped out the ring with teeth on it thats on the crank shaft also?it fires up and runs idles fine just will not take throttle?will a bad tps sensor cause it?
wvjeepman2014 is offline   Reply With Quote Quick reply to this message
Unread 06-04-2014, 08:16 PM   #6
02blue
Registered User
2002 KJ Liberty 
 
Join Date: Aug 2011
Location: Frederick, MD
Posts: 435
I got a code when my TPS crapped out. Might check it anyway or the IAC.
__________________
"Hey, ya never know til you try." Kurt Russell-Big Trouble in Little China
02blue is offline   Reply With Quote Quick reply to this message
Unread 06-04-2014, 08:35 PM   #7
02blue
Registered User
2002 KJ Liberty 
 
Join Date: Aug 2011
Location: Frederick, MD
Posts: 435
I wouldn't ignore the injector issue too. Did you put in 03 or 04 injectors when you changed 3 of them? Could be Cats or O2 sensors (upstream) fuel pump... seems like there should be a code for many possible issues.
__________________
"Hey, ya never know til you try." Kurt Russell-Big Trouble in Little China
02blue is offline   Reply With Quote Quick reply to this message
Unread 06-05-2014, 06:21 PM   #8
wvjeepman2014
Registered User
 
Join Date: May 2014
Location: princeton, wv
Posts: 20
i got a code i need to check n i put all 03 injectors back in it?i asked a guy at a local garage he doesnt seem to think the injectors being 03 would cause the issue?a bad tps would cause it?i was thinking run a fuel pressure test on it and a code scan?
wvjeepman2014 is offline   Reply With Quote Quick reply to this message
Unread 06-05-2014, 08:15 PM   #9
02blue
Registered User
2002 KJ Liberty 
 
Join Date: Aug 2011
Location: Frederick, MD
Posts: 435
I would think it better to put the 03 injectors with the 03 computer but can't say for sure. The TPS should give you a code if that's it. Mine was all weirded out when my TPS failed.

Let us know what the code is.
__________________
"Hey, ya never know til you try." Kurt Russell-Big Trouble in Little China
02blue is offline   Reply With Quote Quick reply to this message
Unread 06-06-2014, 04:16 AM   #10
wvjeepman2014
Registered User
 
Join Date: May 2014
Location: princeton, wv
Posts: 20
ok 02blue i got a 04 jeep the computer and everything is 04 only thing o3 is the injectors...............i put a scanner on the thing i got a crankshaft camshaft position censor correlation code and tps sensor code and a injector cylinder 1 open circuit?does it sound like its out of time to u or whats this mean?
wvjeepman2014 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.