03 liberty, batt lite on dashboard ??'s - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 03 liberty, batt lite on dashboard ??'s

Dan's Old as Dirt Birthday Sale!Advance Adapters SYE KitsRIGID LED Light Blowout Sale - All Sizes, All Series, all

Reply
Unread 07-28-2014, 04:21 PM   #1
88dually
Registered User
2003 KJ Liberty 
 
Join Date: Dec 2012
Location: Ocean County, NJ
Posts: 22
03 liberty, batt lite on dashboard ??'s

wife started car, battery light came on, after market volt gauge said 12. after running a few seconds, lite went out an gauge went to 14. Does that light mean alt is going bad ?

88dually is offline   Reply With Quote
Unread Yesterday, 07:53 AM   #2
Billwill
Registered User
2002 KJ Liberty 
 
Join Date: Jul 2007
Location: South Africa
Posts: 971
Quote:
Originally Posted by 88dually View Post
wife started car, battery light came on, after market volt gauge said 12. after running a few seconds, lite went out an gauge went to 14. Does that light mean alt is going bad ?
Could be a loose connection somewhere.
The alternator does not have a built in regulator but is controlled externally by the PCM....make sure the two-pin plug and the large cable on the alternator are on clean and tight and maybe disconnect the battery and re-plug the PCM connectors a few times to clean them up.

Bear in mind that the early KJs have a Battery Temperature Sensor located under the battery...senses battery temperature so that the PCM can accordingly adjust the charging rate.....any problem with this sensor also lights up the same battery light on the console that a charging issue will light up...I had this battery temperature sensor issue.

If you can pull codes you will see if it is a charging issue or a Bat temp sensor issue.....if the problem comes back then let us know and I will give you some pointers on what to do!
__________________
2002 2.5 Export CRD Manual 5 speed.
Billwill is offline   Reply With Quote
Unread Yesterday, 10:51 AM   #3
remmons
Some assembly required.
2002 KJ Liberty 
 
Join Date: Mar 2010
Location: Vernal, Utah
Posts: 1,530
I agree with Billwill. Check all of the battery terminal and alternator connections to make sure that they are all clean and tight. This is usually the first step in determining the problem. Also check to see how tight that the battery cables feel inside the crimped ends. When I use to work in the auto parts field I've had a few customers who couldn't diagnose a poor starting or charging issue even after replacing everything except the battery cables until I had suggested this point.
__________________
2002 Liberty Sport 3.7. 2.5" lift.

http://www.jeepforum.com/forum/f12/i...t-case-989208/
remmons is offline   Reply With Quote
Unread Yesterday, 06:12 PM   #4
88dually
Registered User
2003 KJ Liberty 
 
Join Date: Dec 2012
Location: Ocean County, NJ
Posts: 22
the car sat all day during work. so i;m not sure about the temp sensor.
everythings tight on alt an batt.
i checked for codes an zero, no codes.
88dually is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.