post #1 of Old 04-04-2013, 08:57 AM Thread Starter
res0n0xg
Registered User
1994 ZJ 
 
Join Date: May 2011
Location: Carrollton
Posts: 75
02 Liberty Heat not working

It's an 02 Liberty Sport, heat simply won't even turn on, what would be the process to check to see why not? Despite where the knob is set, it simply blows ice cold AC, nothing else.

Is this something super simple I'm missing?

res0n0xg is offline  
post #2 of Old 04-04-2013, 09:42 AM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,361
Have you checked your coolant level?

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is online now  
post #3 of Old 04-04-2013, 09:49 AM Thread Starter
res0n0xg
Registered User
1994 ZJ 
 
Join Date: May 2011
Location: Carrollton
Posts: 75
coolant level looked fine in the tank, no overheating or anything, why?
res0n0xg is offline  
post #4 of Old 04-04-2013, 09:53 AM
tjkj2002
Registered User
2002 KJ Liberty 
 
Join Date: Dec 2009
Location: Colorado
Posts: 8,361
Quote:
Originally Posted by res0n0xg View Post
coolant level looked fine in the tank, no overheating or anything, why?
Low coolant is the biggest reason for little or no heat.


Next step is to check the blend door actuator,it's electric unlike the mode doors which are run by vacuum.It's tucked way up top of the HVAC box,almost impossible to get to and dash removal is required to change.

'02 Liberty sitting on 35" tires,HP44,RockJock60,and AtlasII t-case
tjkj2002 is online now  
post #5 of Old 04-04-2013, 11:31 AM Thread Starter
res0n0xg
Registered User
1994 ZJ 
 
Join Date: May 2011
Location: Carrollton
Posts: 75
Sadly that probably could be it, as it's not blowing luke warm, or mild, it's definitely activating the AC compressor still and blowing cold air.
res0n0xg is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome