02 Liberty hard to start runs rough - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 02 Liberty hard to start runs rough

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineBill Baird Motorsports DIY parts - NalinMFG.comComponent speaker deal for your dash - NalinMFG

Reply
Unread 06-17-2013, 07:07 AM   #1
if_i_only_knew
Registered User
 
Join Date: Jun 2013
Location: lexington, ky
Posts: 1
02 Liberty hard to start runs rough

Difficult to start, runs/idles rough until you reach about 55mph. Changed plugs and pulled a few codes said the #1 and #5 are misfiring, after plugs no misfire codes just no imporvement on run/idle.

if_i_only_knew is offline   Reply With Quote
Unread 06-17-2013, 05:26 PM   #2
streetglideok
Web Wheeler
2005 KJ Liberty 
 
Join Date: Jul 2011
Location: Colorado Springs, Colorado
Posts: 2,343
You put the NGK copper plugs gapped to oe spec on the emission sticker, correct? You may have suffered a coil failure, or multiple coil failure, or possibly injector issues. Either will cause your symptoms. You'll have to drive it some to re-trigger misfire codes, they won't always set in the driveway. See if the misfires are still on the same cylinders. If so, swap the coils for those cylinders to different cylinders, and note where you put them. Clear codes, drive it and see if codes return for misfires where you put the coils. Also, you need to reset the fuel trims after doing a repair like you did, otherwise it may run poorly until it finally relearns.
streetglideok is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.