02 Jeep Liberty Low Oil Pressure Light - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KJ Liberty Forum > 02 Jeep Liberty Low Oil Pressure Light

Spartan Locker Promo Running now @ ROCKRIDGE 4WD plus FREEG2 Disc Brake Conversion Kit for Jeep Wrangler YJ TJ LJ ChSave 15% in XT's Pre-Black Friday Event!

Reply
Unread 11-24-2007, 12:36 PM   #1
captainfarrell
Registered User
 
Join Date: Nov 2007
Location: Worcester, MA
Posts: 3
02 Jeep Liberty Low Oil Pressure Light

Anybody? Is this common? Light comes on intermittently and oil is up and relatively new, nice amber color.

I'm hoping it's not the oil pump.

I have an 8/80 warranty and I'm on 79,758

Do you think this will be covered?

Anybody?

Any help is appreciated.

Kevin

captainfarrell is offline   Reply With Quote Quick reply to this message
Unread 11-24-2007, 01:05 PM   #2
RIDGEZ28
Registered User
 
Join Date: Nov 2007
Location: OHIO
Posts: 3
low oil pressure

It's probably the sending unit, but take it in right now.
RIDGEZ28 is offline   Reply With Quote Quick reply to this message
Unread 11-24-2007, 01:12 PM   #3
Avian
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2007
Location: Michigan
Posts: 1,810
Quote:
Originally Posted by RIDGEZ28
It's probably the sending unit, but take it in right now.
Id say so to. And definitely take it in ASAP if you want any hope of it being covered.
Avian is offline   Reply With Quote Quick reply to this message
Unread 11-24-2007, 05:30 PM   #4
captainfarrell
Registered User
 
Join Date: Nov 2007
Location: Worcester, MA
Posts: 3
Where is the sending unit? Down in the bowels of the frign motor?

Thanks, Kevin
captainfarrell is offline   Reply With Quote Quick reply to this message
Unread 11-24-2007, 06:33 PM   #5
COLORADO
Registered User
2007 JK Wrangler 
 
Join Date: Mar 2007
Location: COLORADO SPRINGS
Posts: 154
Same thing happened to me, Oil pressure sensor failed.
COLORADO is offline   Reply With Quote Quick reply to this message
Unread 11-24-2007, 10:52 PM   #6
Avian
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2007
Location: Michigan
Posts: 1,810
Quote:
Originally Posted by captainfarrell
Where is the sending unit? Down in the bowels of the frign motor?

Thanks, Kevin
It should either be near the oil pump, or it should be on the main oil bus (forgot the proper term for it) near the filter.

What engine does the liberty have? 2WD or 4WD?
Avian is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.