post #1 of Old 09-03-2012, 07:32 AM Thread Starter
jeepgirlok
Registered User
 
Join Date: Sep 2012
Posts: 1
02 liberty burning oil

I have 155k miles on my jeep and I am burning oil like crazy. In a 3 week span I have put 2 quartz of oil in it . It runs great , just burning oil. What could cause this?

jeepgirlok is offline  
post #2 of Old 09-08-2012, 08:31 AM
johnscott
Registered User
 
Join Date: Sep 2012
Posts: 1
Quote:
Originally Posted by jeepgirlok
I have 155k miles on my jeep and I am burning oil like crazy. In a 3 week span I have put 2 quartz of oil in it . It runs great , just burning oil. What could cause this?
Sounds like you have problems with sticking oil control rings on the pistons , my 02 3.7 was the same , I used Kleen Flow combustion cleaner & an oil flush treatment , plus a new pcv vale this has greatly reduced my oil burning problem !!
johnscott is offline  
post #3 of Old 10-01-2012, 05:13 PM
lukesdyer
Registered User
2002 KJ Liberty 
 
Join Date: Sep 2012
Posts: 3
I have a similar problem with my 02 liberty sport. Currently I have a case of oil in the back and check it weekly to be safe. Typically I put a quart in when it gets a quart low.

How much did it cost to replace the seals?
lukesdyer is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome