Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Jeep Registry > WJ Grand Cherokee > Grand Cherokee Laredo 4.0 Losing oil somewhere??

Black Friday Sale - Deep Discounts from ExtremeTerrain.com6th Annual, Beat Your Wife to the Credit Card Sale!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Grand Cherokee Laredo 4.0 Losing oil somewhere?? Jeep Registry
Previous Jeep WJ Grand Cherokee Next Jeep

Grand Cherokee Laredo 4.0 Losing oil somewhere??

Email Bookmark Print
Newtojeeps88
Registered User
Eagle Butte

Jeep Information

Year:1999

Model:Grand Cherokee Laredo

Engine:6 cyl 4.0

Transmission:Automatic


I am losing oil in my jeep and cant find where.. here's the history:

A month ago after changing the front brakes i took my jeep for a drive.. about 20 miles, everything seemed to be going good.. i started my return trip and noticed i was running hot.. so i turned around and parked at my sisters to check out what was going on.. after a couple weeks i got to working on it, i changed the thermostat and the culprit was the water pump. so new brakes, thermostat and water pump and its all looking good.. 20 mile drive back and i noticed the oil pressure gauge fluctuate a little and an oil burning smell..

after driving for a week i have had to put in about 1 qt. of oil a week and one on the day of another 40 mile round trip.. checked the dip stick before all that and it looked spotty (oil here and there on the dip stick and not a solid covering of oil) when its parked I'm finding theirs not a lot of dripping on under it (after refilled with oil) the block is pretty covered in oil and i'm not smelling any antifreeze or seeing any mixed with the oil after running it for a while. but i am losing oil some where..

My question is this.. I notice a greater oil loss when driving at highway speeds for a period of time (30 - 40 miles) and with there not being a lot of leaking when parked.. I'm working do you think the oil loss can be from the Valve covers? like worn Valve gaskets due to the block being covered and maybe blowing down onto the exhaust? or do you think there maybe another issue I'm not considering? ask any questions will answer as soon and as best i can.

Tags
None

Login Or Register To Post Comments

CGlaser
Registered User
View CGlaser's Jeep
12-28-2013, 04:04 AM
Hows the valve cover gasket? When was the last time you changed oil?


Newtojeeps88
Registered User
View Newtojeeps88's Jeep
12-28-2013, 04:21 AM
I have not changed the Valve cover gasket, and wondering if that is the issue and cause of the loss of oil, its losing a lot, and wasn't sure if a quart can be lost from the valve cover gasket leaking? and the last time i changed my oil was about 3 months ago and have not had an issue with any oil loss until recently will double check to make sure the oil drain is tightened in case it worked loose.


CGlaser
Registered User
View CGlaser's Jeep
12-28-2013, 04:27 AM
Chrck around thr valve cover to see if its been leaking. That would explain the buring smell. Its it leaking at all around your oil pan? Main? I was worried if you changed oil soon that the old seal from the previous oil filter could have stuck. Doubling those gaskets will make it leak. I did loose oil when my valve cover was leaking but not that much. what kind of oil are you running?


Newtojeeps88
Registered User
View Newtojeeps88's Jeep
12-28-2013, 04:36 AM
I will check around the valve cover later today, as i said below the valve cover on the block its covered in crud/oil.. will take come cleaner to it and hose it off a few times so i have a better look at things. the oil loss was worse when driving at highway speeds, then compared to just in town driving. when i last changed my oil i made sure the old oil filter gasket was off before replacing it. i have put some card board under my jeep to maybe see where its leaking but its winter and warm so its covered in all kinds of dirty stuff just from all the wet road grime so will have to figure out how to work that out so i can see if its really leaking from a certain area underneath. I have only had my jeep for a year so the only things i know about it are just the things i've done to repair at this point.

Think i will also do an oil change, since its due, and replace with another brand filter just so its a starting point and i know its done and ruled out.


CGlaser
Registered User
View CGlaser's Jeep
12-28-2013, 04:51 AM
I use a bosch filter on mine. Also. If you run synthetic or sythetic blend it can cause a small leak to seem larger


Newtojeeps88
Registered User
View Newtojeeps88's Jeep
12-28-2013, 05:06 AM
I am not sure what kind of filter i used.. just what ever they had on the last change, and i use penzoil 10w30 no a synthetic or blend.







Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.