post #1 of Old 06-18-2014, 05:45 PM Thread Starter
TheKennyDV
Registered User
 
Join Date: Apr 2014
Posts: 4
Throttle

Hey Guys my 98 XJ has a problem where it shuts off when I come to a stop 20% of the time. The radio keeps playing so it's not the battery. It happened after I hadn't driven the jeep for a couple days and my battery died cause a light in the jeep stayed on. So I charged it and now this started happening. I've heard sea foaming the jeep would be a good solution? Any other idea as on what it could be or what's a good solution? Thanks!

TheKennyDV is offline  
post #2 of Old 07-02-2014, 04:58 PM
JMH21814
Registered User
1997 XJ Cherokee 
 
Join Date: Jan 2013
Location: Enfield
Posts: 297
Just off the top of my head, I'd say crank position sensor, maybe cam, but more likely crank. Gotta do some testing. Btw, welcome to JF!
JMH21814 is offline  
post #3 of Old 07-25-2014, 09:31 PM
nicco196
Registered User
 
Join Date: Jul 2014
Posts: 35
Crank position sensor is where I'd start.
nicco196 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome