Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Jeep Registry > XJ Cherokee > Need HELP!!!!!!

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: Wranger BRIGHT License Plate LED! Just $3! Great valueThanksgiving/Black Friday/Cyber Monday Deals at JeepinOutf

Need HELP!!!!!! Jeep Registry
Previous Jeep XJ Cherokee Next Jeep

Need HELP!!!!!!

Email Bookmark Print
sccarr54
Registered User
San Jose

Jeep Information

Year:1995

Model:Cherokee XJ

Engine:4.0

Transmission:auto


Hey everyone, I'm new on here and need all the help I can get. So here it is. My son has a 95 cherokee Xj with a 4.0 straight 6 in it. Here's the problem. He was driving and the thing started to just die. It's like you just shut down the key. So I started doing research and spending alot of money. I have changed the coil,wires,plugs,cap and rotor first and nothing. Next I read that the CPS could be the problem so I changed that and nothing. Next I changed PCM and again nothing. So I changed the MAP sensor and the TPS sensor along with the camshaft position sensor and still nothing. I even went as far as trying a different CPS. I'm stuck and need help!!! ANYONE PLEASE.

Tags
None

Login Or Register To Post Comments

sccarr54
Registered User
View sccarr54's Jeep
03-21-2014, 07:13 PM
No one on here has any clue?


irish82bikes
Registered User
View irish82bikes's Jeep
03-22-2014, 01:47 AM
What does it do when you turn the key and try to start it?


sccarr54
Registered User
View sccarr54's Jeep
03-24-2014, 06:01 PM
So when I turn the key it starts and will run for awhile but then it just cuts out again. This weekend I changed the starter and the IAC sensor. Ran for awhile and then same thing. I just don't get it. The only thing I haven't changed is the o2 sensor,but would that not have the vehicle have spark?


JeepinJeremy

Registered User
View JeepinJeremy's Jeep
03-24-2014, 06:04 PM
Did you even check fuel pressure before you started dumping money into it? Just cause the pump comes on doesn't mean its good.


irish82bikes
Registered User
View irish82bikes's Jeep
03-24-2014, 10:01 PM
Sccarr text or call me I work 3-11 so before or after those hours would be easier and faster. 608 343 7068


draxxusxj
Registered User
View draxxusxj's Jeep
03-25-2014, 06:03 AM
Fuel filter
Not sure if this will fix your problem but had an old CRX that would do this..... changed the fuel filter and it fixed it. Would run fine until it warmed up and then would die and not start until it cooled down again. Hope this helps


sccarr54
Registered User
View sccarr54's Jeep
03-27-2014, 06:33 PM
Yes, That was the first thing that I checked and yes I changed the fuel filter as I was doing that process.


psycokid94
Registered User
View psycokid94's Jeep
07-04-2014, 05:02 PM
KISS (keep it simple stupid)
Check that the fuel is actually getting to the engine, and if so how much
-Fuel pump
-sending unit
-filter as said above
-fuel rail pressure
-Fuel regulator
-injectors

Also check the ignition switch itself. And also another thought check the alternator and batter, and all of your ground wires.

I am not saying to spend a bunch of money replacing all of this stuff, but just check it to make sure those things are functioning properly.

Just some thoughts if you haven't found the problem yet.


nicco196
Registered User
View nicco196's Jeep
07-26-2014, 12:09 AM
Is it running hot when it shuts off or normal running temp? And when it dies do dash lights stay on?


nicco196
Registered User
View nicco196's Jeep
07-26-2014, 12:12 AM
And I would have thought CPS at first. Pretty common prob on an xj. A lot of times they have thermal failure and work again after it cools.







Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.