post #1 of Old 09-18-2012, 03:31 AM Thread Starter
GrizzlyKidd94
Registered User
 
Join Date: Sep 2012
Posts: 8
back fires barley runs

I have a 88 cherokee with a 4.0 auto. i recently replaced the tranny after it sat around for a year or so and now im having problems with it back firing threw the exaust and throttle body. it has zero throttle response idles really rough and will not idle for more then a minute. Jeep ran amazing before tranny went out i have replaced injectors and did a full tune up. Really need help please i have no idea what it could be thanks.

GrizzlyKidd94 is offline  
post #2 of Old 09-18-2012, 04:19 PM Thread Starter
GrizzlyKidd94
Registered User
 
Join Date: Sep 2012
Posts: 8
[QUOTE="GrizzlyKidd94"]I have a 88 cherokee with a 4.0 auto. i recently replaced the tranny after it sat around for a year or so and now im having problems with it back firing threw the exaust and throttle body. it has zero throttle response idles really rough and will not idle for more then a minute. Jeep ran amazing before tranny went out i have replaced injectors and did a full tune up. Really need help please i have no idea what it could be thanks could really use some advice
GrizzlyKidd94 is offline  
post #3 of Old 10-12-2012, 07:12 AM
JeepXJ20
Registered User
1999 XJ Cherokee 
 
Join Date: Oct 2012
Posts: 21
Might not have anything to do with tranny. Check the timing on the distributor and also check the ignition coil too see if it has any cracks and what not.
JeepXJ20 is offline  
post #4 of Old 10-18-2012, 04:54 PM
S8NNG8
Web Wheeler
 
S8NNG8's Avatar
1995 XJ Cherokee 
 
Join Date: Feb 2012
Location: Helena
Posts: 7,752
Check to see if your distributor is off 180 degrees. You may think whatever, but turn it around and fire it up.

D3<!L!>3D
S8NNG8 is online now  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome