Smoke while in reverse? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 01-15-2014, 06:21 PM Thread Starter
staredecisisjd
Registered User
 
Join Date: Jan 2014
Posts: 4
Smoke while in reverse?

This morning when I was pulling my 2001 jeep grand cherokee Laredo into a parking spot at work the steering wheel got tight and I heard this really loud sound (it kind of sounded like a popping sound)

When I went to leave work, i went into reverse and white smoke came pouring out of the hood. I stopped the car and took the key out and 10 mins later I started it up again to straighten out in the spot which included going in reverse and it wasn't smoking but was making a creeking sound.

Any idea what could be wrong?

staredecisisjd is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-18-2014, 12:44 AM
uberxj92
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2012
Location: umatilla
Posts: 1,961
Sounds like a blown power steering hose. Or maybe one of them is loose.

http://www.jeepforum.com/forum/f177/92-xj-sadness-2075657/index2.html
uberxj92 is offline  
post #3 of 6 Old 01-19-2014, 09:08 AM
JIMBOX
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2008
Location: NORCAL/NORNV
Posts: 7,218
Sounds like power steering failure--did you even look ??

JIMBO

Yellow Jeep No. 683

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

--YA GOTTA HAVE CLASS--
JIMBOX is offline  
post #4 of 6 Old 01-19-2014, 09:47 AM Thread Starter
staredecisisjd
Registered User
 
Join Date: Jan 2014
Posts: 4
It actually turned out to be my transmission.
staredecisisjd is offline  
post #5 of 6 Old 01-19-2014, 09:51 AM
JIMBOX
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2008
Location: NORCAL/NORNV
Posts: 7,218
WOW, Ida never even considered the tranny--

Thanx for the quick comeback, could be an expensive fix !


Quote:
Originally Posted by staredecisisjd View Post
It actually turned out to be my transmission.
JIMBO

Yellow Jeep No. 683

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

--YA GOTTA HAVE CLASS--
JIMBOX is offline  
post #6 of 6 Old 01-19-2014, 04:42 PM Thread Starter
staredecisisjd
Registered User
 
Join Date: Jan 2014
Posts: 4
I actually paid nothing for it because it's under warranty since the tranny was replaced 6 months ago.

Thanks,
staredecisisjd is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome