No cruise in KJ Liberty - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > General Jeep & Off-Road Equipment > No cruise in KJ Liberty

Premium LED Lighting by VISION X, Proudly sold at ROCKRIDGFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 09-11-2010, 10:18 AM   #1
JeepLDon
Registered User
2003 KJ Liberty 
 
Join Date: Sep 2010
Location: Oshawa
Posts: 7
No cruise in KJ Liberty

Hello, I have a 2003 Liberty Sport 4x4 and the cruise does not work properly as does the speedo. The speedo bounces around until the brake is applied a few times then steadies out, at the wrong speed reading. The cruise is probably not working because of this erratic behaviour.
The Mopar dealer has gone through the wiring, supposedly and the problem was fixed for about 2 days then went right back to being erratic. I am thinking that the brake light switch might be at fault or the electrics to the cruise from the ECM or PCM. Everything else works fine and the car drives and shifts perfectly, so I am not suspecting the speed sensors.

Any suggestions? The wire pinched at the brake line is not an issue here.

JeepLDon is offline   Reply With Quote
Reply

Tags
cruise control , liberty , speedometer , sport
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.