No cruise in KJ Liberty - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 09-11-2010, 11:18 AM Thread Starter
JeepLDon
Registered User
2003 KJ Liberty 
 
Join Date: Sep 2010
Location: Oshawa
Posts: 7
No cruise in KJ Liberty

Hello, I have a 2003 Liberty Sport 4x4 and the cruise does not work properly as does the speedo. The speedo bounces around until the brake is applied a few times then steadies out, at the wrong speed reading. The cruise is probably not working because of this erratic behaviour.
The Mopar dealer has gone through the wiring, supposedly and the problem was fixed for about 2 days then went right back to being erratic. I am thinking that the brake light switch might be at fault or the electrics to the cruise from the ECM or PCM. Everything else works fine and the car drives and shifts perfectly, so I am not suspecting the speed sensors.

Any suggestions? The wire pinched at the brake line is not an issue here.

JeepLDon is offline  
Reply

Tags
cruise control , liberty , speedometer , sport

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
cruise control ftgjeeper Audio, CB & Ham Radios, GPS, & Electrical 3 05-10-2010 09:38 AM
Cruise + horn don't work. XJcrazy00 Audio, CB & Ham Radios, GPS, & Electrical 10 12-28-2009 10:37 PM
Just got back from a cruise xjken99 Street Jeep Forum 4 05-26-2008 02:32 PM
Which relay/fuse for Cruise? chrisvr6 Audio, CB & Ham Radios, GPS, & Electrical 0 03-15-2005 11:02 AM
cruise control ANDY31259 Audio, CB & Ham Radios, GPS, & Electrical 3 01-31-2005 07:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome