Need help! -
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back > General Technical Discussions > General Jeep & Off-Road Equipment > Need help!

Black Magic Brakes is having an extended Black Friday Sale6th annual beat your wife to the credit cards sale!!Get ready!! CyberMonday deals are coming!!!

Unread 08-07-2011, 09:24 PM   #1
Registered User
2001 XJ Cherokee 
Join Date: Jun 2011
Location: Scranton, Pa
Posts: 16
Need help!

Okay so,the other night I was coming home and I hit a gnarly pothole, and my 2001 Cherokee Sport shut off abruptly. I then turned it back on a few seconds later, and drove it a good 25 miles home with no problems. After having it sit until the following evening, I went to turn it on, but to no avail. It didn't rev or anything, it would just click a single time when I turned the key, and all my readouts (oil, fuel, coolant, battery power, etc.) were normal. So today I thought that maybe it was a ground, so I checked my chasis ground by the battery, and it was fine. I then checked my replacement JVC CD stereo's ground and found that it was only halfway on, so I put it back on all the way. Nothing changed. So, I took the whole stereo and the adapter I had for it out, and the car started right up. So, I re-wired the adaptor and re-installed the radio, and the car started right up. So, about an hour later I went to take my girlfriend home, AND IT WOULDN'T START, IT JUST CLICKED WHEN I TURNED THE KEY. Luckily, I have my Dodge pickup.
I'm pulling my hair out over this, so anything you guys can tell me is more than greatly appreciated.

the_red_ranger is offline   Reply With Quote Quick reply to this message
Unread 08-10-2011, 09:18 AM   #2
Registered User
1994 ZJ 
Join Date: Aug 2011
Location: oskaloosa, iowa
Posts: 535
well if it only clicks and nothing runs u might wanna check ur starter or ur auto shutdown relay i beieve. i has dsimiliar thing but i disconected my alarm.
caligiuri87 is offline   Reply With Quote Quick reply to this message
Unread 08-10-2011, 09:56 AM   #3
Registered User
1995 YJ Wrangler 
Join Date: Dec 2005
Location: Sacramento
Posts: 283
Well, if I had to guess, sounds like when you tagged that pothole, something disconnected or stopped the alternator from generating power. Maybe a ground or something, because when it got going again, it sounds like you were running on battery only. Your battery eventually drained and that's why you can't start it. That would have been my first guess, but since you say you've got full power on the battery it is more likely something like a bad ground wire which is super common. Corrosion on the batt terminals, ground wire corrosion at block on terminal, frayed, etc. Just something to check.
"Aut viam inveniam aut faciam" - I will either find a way or I will make one.
1995 YJ, SOA, D44/60, 35"s
2008 Dodge Ram SLT 4x4
unrealtrip is offline   Reply With Quote Quick reply to this message

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools

Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. is not in any way associated with Jeep or the Chrysler Corp.