Heater blows smoke? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > General Jeep & Off-Road Equipment > Heater blows smoke?

RIGID LED Light Blowout Sale - All Sizes, All Series, all Truc-Lite LED Headlights! OCONEE OFF-ROAD 706-534-9955Jeep Wrangler Bushwacker Flat Fender Flare Sale at Baselin

Reply
Unread 11-04-2013, 08:56 AM   #1
daryl50
Registered User
2005 TJ Wrangler 
 
Join Date: Oct 2013
Location: Moab, UT, UT
Posts: 57
Heater blows smoke?

I recently bought a 2005 Rubicon with 70k on it. Now that it has cooled down outside, I've noticed that when first turning the heat on or whenever changing the air temp dial from cool to warm or vice versa, smoke blows out of my vents and to me it smells like burning radiator fluid. This only last for about 30 seconds, or occasionally a little longer. I can't find any leaking radiator fluid and there are no leaks on the ground. Has anyone seen this before or know what the problem is?

daryl50 is offline   Reply With Quote Quick reply to this message
Unread 11-04-2013, 09:00 AM   #2
drexelsteve
Registered User
2013 JK Wrangler 
 
Join Date: Sep 2004
Location: Goose Creek SC
Posts: 1,181
The heater core is leaking. Not a difficult repair but it is labor intensive involving removing the instrument panel (the whole dash).
__________________
13 Rubi
drexelsteve is offline   Reply With Quote Quick reply to this message
Unread 11-04-2013, 09:10 PM   #3
Indy
Registered User
 
Join Date: Oct 2004
Location: WY
Posts: 2,981
Yep, steam not smoke. Heater cores are the debil.
__________________
Odds are im typing on a tablet. It takes too much effort to add some punctuation. Im lazy, get over it

Never underestimate the power of stupid.
Indy is offline   Reply With Quote Quick reply to this message
Unread 11-04-2013, 09:19 PM   #4
daryl50
Registered User
2005 TJ Wrangler 
 
Join Date: Oct 2013
Location: Moab, UT, UT
Posts: 57
Son of a...... I tried some K-Seal in it tonight...seems to be working. I'm gonna keep my fingers crossed.
daryl50 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.