94 Jeep wrangler wont start....HELP PLEASE!!! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > General Jeep & Off-Road Equipment > 94 Jeep wrangler wont start....HELP PLEASE!!!

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 10-05-2012, 01:30 AM   #1
NIGHTHAWK159
Registered User
1994 YJ Wrangler 
 
Join Date: Oct 2012
Location: ALBUQUERQUE, NEW MEXICO
Posts: 1
94 Jeep wrangler wont start....HELP PLEASE!!!

I've got a 94 jeep wrangler 2.5L 4cyl that wont start or even attempt to start. I've had issues with my battery being drained before and all I've had to do was charge the battery and it starts right up, no problems. This last time I tried that and my battery was bad so I replaced the battery and threw it in and it didnt change anything. When you turn the key halfway it buzzes for the seatbelt warning and the warnings on the dash come on but they are really weak and intermittent. If you leave the key in then they become brighter but they are still cutting out. When you turn the key to start it, the lights turn off and nothing happens, no clicking of the relay or starter trying to turn over. Nothin. When you stop trying to start it the lights on the dash come back up but they are really weak again. When you try turning the lights on, the dash ones turn off and the lights dont come on. I replaced the starter maybe 6 months ago and the positive cable was redone where it attaches to the battery. Like I said, I've had problems with a draining battery in the past year but charging it has always fixed it, it would even turn over if you jumped it but now when you try and jump it, nothing happens. It doesnt even get the lights to come on after 10 minutes of being attached. Please help me because this is my daily driver. Thnaks guys

NIGHTHAWK159 is offline   Reply With Quote
Unread 10-05-2012, 07:15 PM   #2
rjbruzan
Moderator
2004 TJ Wrangler 
 
Join Date: May 2008
Location: Lake in the Hills, illinois
Posts: 1,935
There is still a loose or dirty connection somewhere. Disconnect the battery and start at the starter making sure the connections are clean and tight. Also check the grounds. If it wont turn over with the charger on the voltage is not getting to the starter.
__________________
Of all the things Ive lost
The one I miss most is my mind

Its like a fart in a windstorm
It smells good but thats about it

Registered Six Offender
Home of the Buzzin Half Dozen
rjbruzan is offline   Reply With Quote
Unread 10-11-2012, 09:56 PM   #3
xxxxxxxTunesUpTopDown
Guest
1993 YJ Wrangler 
 
Join Date: Aug 2012
Location: , Washington
Posts: 97
I had this problem for Weeks with my 93 yj. After countless attempts, I fould out that there was enough corrosion between the battery post and the cable that it wasnt getting power. The exact same thing you're describing is what I was expiriencing. Had to take a wire brush to the inside of the terminal. Worked fine since. Hope it helps.
xxxxxxxTunesUpTopDown is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.