Tranny shaft not turning - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 07-03-2013, 09:07 AM Thread Starter
Smelly2u
Registered User
1992 YJ Wrangler 
 
Join Date: Oct 2012
Location: Surrey
Posts: 36
Tranny shaft not turning

Put in my new clutch and pilot bearing with alignment tool felt like I have tranny lined sits flush on engine bolts are in but not cranked on. My question why does my shaft seem so tight can't get it to turn by hand? Ps this my first attempt so I may be missing something simple here

Smelly2u is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome