Reviving a 1990 Sahara YJ :D - Page 3 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #31 of 91 Old 10-04-2013, 01:28 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Well, got the ICM on and it's still hesitant to start. I'll be replacing the ignition coil today to see if that works since I don't think it's getting a spark. The spark plugs, distributor cap & wires all look good, but I guess those will be replaced next followed by the distributor. Any other suggestions? It's killing me not to be able to drive it, lol.

Meepz is offline  
Sponsored Links
Advertisement
 
post #32 of 91 Old 10-04-2013, 03:47 PM
ReDinTX
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: San Antonio
Posts: 187
Quote:
Originally Posted by Meepz View Post
Well, got the ICM on and it's still hesitant to start. I'll be replacing the ignition coil today to see if that works since I don't think it's getting a spark. The spark plugs, distributor cap & wires all look good, but I guess those will be replaced next followed by the distributor. Any other suggestions? It's killing me not to be able to drive it, lol.
Diagnose a bit before just throwing parts at it. Check to see if youre getting spark. Either buy an inline spark tester or just pull a plug, connect to plug wire, and securely ground it while a partner cranks for a second or two.

-ReD
Fire Lieutenant/Paramedic
San Antonio, Tx
'90 Yj 4.2L 5spd
ReDinTX is offline  
post #33 of 91 Old 10-04-2013, 07:54 PM
befumo
Registered User
1989 YJ Wrangler 
 
Join Date: Sep 2008
Posts: 829
Quote:
Originally Posted by rambo3489 View Post
^^NOW that's a cool story. Sorry to hear about your Dad. But hes happy it's in your hands now.
Yeah man that is awesome.

'89 YJ Wrangler - Sold
'95 ZJ Orvis Edition
'89 YJ Islander
befumo is offline  
post #34 of 91 Old 10-05-2013, 01:55 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
I guess it was partly the ICM. It was sorta hesitant to start and I didn't see any spark with the old one. It tried to start strongly today, but I noticed no fuel was coming from the fuel pump. Went and got a new fuel pump and after a bit of trying to start, it finally fired up. After running for a while and getting everything cleared up, it actually ran pretty good for jeep that's been sitting 10+ years. Gonna check out a vacuum diagram and get a non-toasted carburetor put on. Hopefully it runs smoothly after that.
Meepz is offline  
post #35 of 91 Old 10-05-2013, 05:56 PM
ReDinTX
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: San Antonio
Posts: 187
Awesome man!!

Sent from my iPhone using JeepForum

-ReD
Fire Lieutenant/Paramedic
San Antonio, Tx
'90 Yj 4.2L 5spd
ReDinTX is offline  
post #36 of 91 Old 10-10-2013, 05:35 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Got the carb on. Had to switch a few parts around from the other one, but I guess it works now.

I've looked at the diagram, but I can't figure out which hose connects to this. Does anyone have a picture or something they could post please?

Meepz is offline  
post #37 of 91 Old 10-10-2013, 09:21 PM
jenglish421
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2012
Location: chicopee
Posts: 97
I will check mine out in the morning if you don't get a reply by then
jenglish421 is offline  
post #38 of 91 Old 10-11-2013, 11:07 AM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Quote:
Originally Posted by jenglish421 View Post
I will check mine out in the morning if you don't get a reply by then
That would be nice, thanks.
Meepz is offline  
post #39 of 91 Old 10-11-2013, 01:43 PM
jenglish421
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2012
Location: chicopee
Posts: 97
Name:  image-299198498.jpg
Views: 62
Size:  480.0 KB

It goes to where my hand is, it's above the valve cover on the firewall dead center of the engine compartment
jenglish421 is offline  
post #40 of 91 Old 10-11-2013, 01:55 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Quote:
Originally Posted by jenglish421 View Post

It goes to where my hand is, it's above the valve cover on the firewall dead center of the engine compartment
Thanks!
Meepz is offline  
post #41 of 91 Old 10-11-2013, 02:45 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Well, yesterday it started a bit. Now it'll only start if holding down the gas pedal (which it then cuts off upon letting it go) or opening the choke plate which it'll stay running until it closes.
Meepz is offline  
post #42 of 91 Old 10-13-2013, 11:41 AM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Any suggestions? My head is about to explode. Is this something the nutter bypass could eliminate? Should I get a different carb?
Meepz is offline  
post #43 of 91 Old 10-13-2013, 12:02 PM
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
2010 JK Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,977
Quote:
Originally Posted by Meepz View Post
Any suggestions? My head is about to explode. Is this something the nutter bypass could eliminate? Should I get a different carb?
Post #7 might help you before you swap out the carb.

http://www.jeepforum.com/forum/f8/ca...ttings-929120/

Do you know what was good about the good old days? I wasn't good, And I wasn't old!

Senators and Congressman should wear uniforms like NASCAR drivers so we could identify their corporate sponsors....
laybackman is offline  
post #44 of 91 Old 10-13-2013, 12:12 PM
Xplorer
Registered User
2004 WJ 
 
Join Date: Jan 2008
Location: New Albany Pa.
Posts: 71
Stupid question, but is it new fuel? Is the filter clogged?
Xplorer is offline  
post #45 of 91 Old 10-13-2013, 12:30 PM Thread Starter
Meepz
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Wisconsin
Posts: 61
Quote:
Originally Posted by Xplorer View Post
Stupid question, but is it new fuel? Is the filter clogged?
Yep, new fuel. Also, I don't have the filter attached to the carb at the moment. Does that make much difference?

Quote:
Originally Posted by laybackman View Post
Post #7 might help you before you swap out the carb.

http://www.jeepforum.com/forum/f8/ca...ttings-929120/
I'll try that, thanks.
Meepz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome