jforse-TJ part 2 - Page 34 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #496 of 1073 Old 11-08-2013, 11:13 AM
NashvilleTJ
I miss the snow...
 
NashvilleTJ's Avatar
2004 LJ Wrangler 
 
Join Date: Jul 2010
Location: Nashville
Posts: 814
Don't leave us hangin'!!


Build Thread:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NashvilleTJ is offline  
Sponsored Links
Advertisement
 
post #497 of 1073 Old 11-08-2013, 11:24 AM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by MO2500 View Post
Oh yea?
yea

Quote:
Originally Posted by JJeeper09 View Post
Tell
i just did

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #498 of 1073 Old 11-08-2013, 11:25 AM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by nashvilletj View Post
don't leave us hangin'!!

5.3

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #499 of 1073 Old 11-08-2013, 11:40 AM
MO2500
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: Denver
Posts: 7,191
Quote:
Originally Posted by jforse View Post
5.3


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Instagram: @omsmike
MO2500 is offline  
post #500 of 1073 Old 11-08-2013, 12:16 PM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by MO2500 View Post

Going to run it with the NSG 6speed

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #501 of 1073 Old 11-09-2013, 10:33 AM
kheihn
Registered User
1995 YJ Wrangler 
 
Join Date: Nov 2011
Location: Cedar
Posts: 70
I was going to say do the 5.3 over the 5.9 on NSW but forgot to hit send!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kheihn is offline  
post #502 of 1073 Old 11-09-2013, 11:10 AM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by kheihn View Post
I was going to say do the 5.3 over the 5.9 on NSW but forgot to hit send!
Its going to cost more to do, but it is a much better choice.

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #503 of 1073 Old 11-09-2013, 02:49 PM
platinum5.9
Registered User
2003 WJ 
 
Join Date: May 2006
Location: Olean
Posts: 2,059
Quote:
Originally Posted by jforse View Post
Its going to cost more to do, but it is a much better choice.
Huh ;-)

03 Grand/WJ-White 4.7HO/QD/242HD Clayton 6" LA,5100,Clayton skid,Custom Rockers,JK OME SS,17"Rock Monsters 33"Interco Irok ND,Muffler delete/MF cats,SOLID D30/BTF D44a,Fawkes,Projectors/HID
platinum5.9 is offline  
post #504 of 1073 Old 11-09-2013, 05:03 PM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Anyone have input on fuel pump/fuel system advice for the swap?

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #505 of 1073 Old 11-09-2013, 05:14 PM
Hendrix
TJOTY 2013
 
Hendrix's Avatar
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: FT Myers
Posts: 4,868
Quote:
Originally Posted by jforse
Anyone have input on fuel pump/fuel system advice for the swap?
Pretty sure I read the TJ pump was plenty for the LS motors.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


K.C.C.O.
Carpe Diem




To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Hendrix is offline  
post #506 of 1073 Old 11-09-2013, 05:15 PM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by Hendrix
Pretty sure I read the TJ pump was plenty for the LS motors.
I thought that was the 2005-up pumps which had higher fuel pressure? I thought the earlier pumps didn't have enough psi.

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #507 of 1073 Old 11-09-2013, 05:26 PM
MO2500
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: Denver
Posts: 7,191
Quote:
Originally Posted by jforse
I thought that was the 2005-up pumps which had higher fuel pressure? I thought the earlier pumps didn't have enough psi.
Correct.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Instagram: @omsmike
MO2500 is offline  
post #508 of 1073 Old 11-09-2013, 05:56 PM Thread Starter
jforse
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2009
Location: Duluth
Posts: 2,009
Quote:
Originally Posted by MO2500
Correct.
So. Since I have the early pump in my fuel cell. Should I buy a later TJ pump or do a different aftermarket pump?

1997 TJ - Build in process.
2004 WJ Freedom Edition 4.7HO
jforse is offline  
post #509 of 1073 Old 11-10-2013, 07:35 AM
Ryanw10
Registered User
1997 TJ Wrangler 
 
Join Date: Nov 2011
Location: West Olive
Posts: 354
I run the stock 97 fuel pump with my 5.3 and no issues.
Ryanw10 is offline  
post #510 of 1073 Old 11-10-2013, 08:10 AM
MO2500
Registered User
1997 TJ Wrangler 
 
Join Date: Mar 2009
Location: Denver
Posts: 7,191
Quote:
Originally Posted by jforse
So. Since I have the early pump in my fuel cell. Should I buy a later TJ pump or do a different aftermarket pump?
I've heard of people running both with a 5.3 and it working fine. I forget the numbers off the top of my head and I'm on my phone or I would search but iirc the early pump is rated roughly 5psi below the later model pump. It's on the low side of the recommended pressure for LS engines. I've also heard of some having minor issues of fuel starvation with old, tired pumps.

Since you have the RCI with rings for the factory pumps it would probably be easiest to run the late model factory pump rather than modify the cell for another top plate. If you were to switch I would consider assembling a in-tank system with center pickup with either a Walbro or Bosch pump very similar to what Wayne at Alltech builds and an external reg and filter. His drop in dual pump setups for Ultra4s are a bit pricey but I'm going to piece together my own system and try to save a little. I'll do a write up in my thread when I get to working on that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Instagram: @omsmike
MO2500 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome