jeep sport - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Jeep Forums > Jeep Builds > jeep sport

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 11-26-2014, 01:54 AM   #1
Calvin62
Registered User
 
Join Date: Nov 2014
Posts: 2
jeep sport

need a little help to identify problem with one of my jeeps
turns over wont start any ideas?

Calvin62 is offline   Reply With Quote Quick reply to this message
Unread 11-26-2014, 05:28 AM   #2
y2k-fxst
Registered User
1964 CJ6 
 
Join Date: Sep 2012
Location: North English, Iowa
Posts: 138
Turn it back up-right?
__________________
Just picking brains, mines worn out!
y2k-fxst is offline   Reply With Quote Quick reply to this message
Unread 11-29-2014, 09:57 AM   #3
indeepwithajeep
Registered User
1998 XJ Cherokee 
 
Join Date: Nov 2013
Location: Portland, Or
Posts: 215
A faulty crank position sensor should eliminate spark and fuel if it's not getting a proper reading.

Quote:
Originally Posted by CJ7-Tim View Post
Troubleshoot and test, before you buy new parts.

The CPS is the most common failure, but not the only one that can cause a no-start.



The most likely cause of it cranks and cranks but won't start up is the Crankshaft Position Sensor (CPS) located on the transmission bell housing. Often this part is also referred to as the CranKshaft Position Sensor (CKP) CPS/CKP failure is very common. The CPS/CKP can stop working with no warning or symptoms and the engine will not run or the engine may randomly stall for no apparent reason.

Crank Position Sensors can have intermittent “thermal failure”. This means that the CPS/CKP fails when engine gets hot, but works again (and will test as “good”) when it cools back down.

Begin with basic trouble shooting of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables and replace as needed. Do the same for the grounding wires from the starter to engine block, and from the battery and engine to the Jeep's frame/body. Jeeps do not tolerate low voltage or poor grounds and the ECM/ECU may behave oddly until you remedy this.



Symptoms –
- Starter cranks and cranks but engine won't start up and run.
- Fuel gauge and voltage gauge may not work or display properly.
- You sometimes will have No Bus on the odometer after 30-60 seconds.
- A failed CPS/CKP may or may not throw a CEL trouble code.
- No spark at the spark plugs.
- Fuel pump should run and prime for 3-5 seconds.

If the CPS/CKP is failed sometimes the OBD-II trouble code reader cannot make a connection to the ECU/computer or cannot read Check Engine Light/MIL codes because the CPS/CKP has failed. Disconnect the code reader, disconnect the CPS/CKP wire connector, and reconnect the code reader. If the code reader establishes contact with the ECU and scans, your CPS/CKP is failed and needs to be replaced.


Diagnostic steps to confirm the CPS is the cause of your no-start


You should be able to verify a bad cps, by unplugging it, and turning the ignition key to on. If the voltage gauge and/or the fuel gauge now displays correctly, replace the CPS.

Unplugging and reconnecting the CPS sensor where it connect to the main harness near the back of the intake manifold usually resets the ECU and if the jeep fires right up after doing this you can bet that the CPS is faulty and needs to be replaced.

Exchange the fuel pump relay and the ASD relay with one of the other similar ones in the PDC to eliminate the relays as the cause of the no-start. Confirm that the fuel pump to runs for 3-5 seconds when you turn the ignition key to ON.

Eliminate the NSS as a cause of no start. Wiggle the shift lever at the same time you try to start. Put the transmission in Neutral and do the same. Do the reverse lights come on when the shifter is in Reverse?

Inspect the wires and wire connectors at the O2 sensors on the exhausts pipe. A short circuit from melted insulation or from broken O2 sensor wires can blow a fuse and the ECU/ECM will loose communication. Don’t get tunnel vision and assume the sensor is bad (unless it tests bad with a meter). Damaged wiring or a dirty connector can inhibit the signal from making it to the computer. Inspect/test/clean/repair wiring or connectors as necessary.


CPS Testing


Crankshaft Position Sensor Connector (CPS/CKP)



.



TESTING PROCEDURE 1991 – 2001 4.0L H.O. engines

1. Near the rear of intake manifold, disconnect sensor pigtail harness connector from main wiring harness.
2. Place an ohmmeter across terminals B and C (See Image). Ohmmeter should be set to 1K-to-1OK scale for this test.
3. The meter reading should be open (infinite resistance). Replace sensor if a low resistance is indicated.

TESTING PROCECURE for 1987 – 1990 4.0 L engines

Test # 1 - Get a volt/ohm meter and set it to read 0 - 500 ohms. Unplug the CPS and measure across the CPS connector's A & B leads. Your meter should show a CPS resistance of between 125 – 275 Ohms. . If the CPS is out of that range by much, replace it.

Test # 2 - You'll need a helper for this one. Set the volt/ohm meter to read 0 - 5 AC volts or the closest AC Volts scale your meter has to this range. Measure across the CPS leads for voltage generated as your helper cranks the engine. (The engine can't fire up without the CPS connected but watch for moving parts just the same!) The meter should show .5 - .8 VAC when cranking. (That's between 1/2 and 1 volt AC.) If it's below .5vac, replace it.


The 2000 and 2001 will have the CPS in the same location on the bell housing, but the wire connector may be on the passenger side, not as shown in the diagram below. Simply follow the wire from the sensor to the connector.

.
indeepwithajeep is offline   Reply With Quote Quick reply to this message
Unread 12-16-2014, 06:48 AM   #4
Calvin62
Registered User
 
Join Date: Nov 2014
Posts: 2
thanks for that info i have three jeeps two with simular problems
Calvin62 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.