'97 TJ - oil pressure question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Jeep Forums > Jeep Builds > '97 TJ - oil pressure question

Rugged Ridge 07-14 JK Sherpa Roof Rack available @ Oconee Rough Country Lift Kits and Parts!Great prices on seating!--Oconee Off-Road

Reply
Unread 09-24-2012, 09:16 PM   #1
jfulton73
Registered User
 
Join Date: Sep 2012
Posts: 7
'97 TJ - oil pressure question

Have a 97 TJ 4.0 I6, 162k miles. Recently oil pressure gauge dropping to zero when stopping. Levels off at stop to about 20 lbs then back to normal 40 lb running. Don't really want to think about a rebuild, but trying to confirm my fear.

Other "issue:"
Ac damper door closes with ac on and engine under load. Back off throttle and door opens. Thinking vacuum issue or damper vacuum switch.

Any and all insight is greatly appreciated. Hobbiest but have rebuilt a Ford 460 which was a blast!

Thanks,
Jim

jfulton73 is offline   Reply With Quote Quick reply to this message
Unread 09-24-2012, 09:47 PM   #2
WhiteMtnJeep
The Punk Made My Day.....
 
WhiteMtnJeep's Avatar
2003 TJ Wrangler 
 
Join Date: Aug 2008
Location: Lakeside, AZ, Arizona
Posts: 3,411
Take the sending unit for the oil pressure out and put a mechanical gauge in to test. It will tell you for sure. Your AC issue is most likely a vacuum leak. Check where the lines attach to the manifold and at the vacuum bottle. Not sure where it is on the 97, but the later years it's under tge battery tray. It's a common issue.
__________________
Silence is Golden, Duct tape comes in Many Colors.

Journeyman Polyphase Meterman IBEW Local 387

Work with enthusiasm as though you were working for the Lord rather than for man.

http://www.treadlightly.org/

Siena Jeep Owner's Member 25

/l ,[____],
l---L -0lllllll0-

()_) ()_)-O-)_)
WhiteMtnJeep is offline   Reply With Quote Quick reply to this message
Unread 09-25-2012, 09:42 AM   #3
jfulton73
Registered User
 
Join Date: Sep 2012
Posts: 7
Quote:
Originally Posted by FernBchJeep
Take the sending unit for the oil pressure out and put a mechanical gauge in to test. It will tell you for sure. Your AC issue is most likely a vacuum leak. Check where the lines attach to the manifold and at the vacuum bottle. Not sure where it is on the 97, but the later years it's under tge battery tray. It's a common issue.
Thank you! I'll give that a try!

Much appreciated!
jfulton73 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.