Wrangler Radio Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Wrangler Radio Issue

JK Front Lower Adjustable Control Arms!QTP Low Profile Cutouts Now @ MarylandSpeed- Free ShippingOPTIC ARMOR WINDOWS all sale now !!!!!!!!

Reply
Unread 05-09-2013, 02:09 AM   #1
ChaffinYJ92
Registered User
 
Join Date: May 2013
Location: Dallas, Texas
Posts: 1
Wrangler Radio Issue

I own a 1992 Wrangler YJ and i have installed 2 little floor speakers in front of my stick shift and had the soundbar done professionally.

The shocks are old and so is the car so the ride is pretty stiff and sometimes when i hit potholes or bumps in the road and it jolts the car the radio ****s out and the sound is terrible and it is scratchy and staticky and sounds like a broken record and is especially noticeable in the bass of the song. The quality only fixes when i turn the volume down pretty low then the distortion goes away. But i cant hear the music lol.

I'm always playing music through my iPod and i figure it must be a wiring issue because taking out and putting the face plate back in and unplugging and plugging back in my iPod doesn't fix the problem, and neither does turning off the engine and restarting.

It usually fixes somehow overnight like its broken when i get home and when i leave the next morning it works again and this puzzles me. So for some reason letting the car sit for a while fixes it. Also the tiniest bumps sometime set this off and sometimes i go over speed bumps at 30 mph and nothing happens so i really am perplexed

Sorry for writing so much I've been battling and cursing at my jeep for a year now with this problem and really need some advice or tips because i really don't want to go pay for it to be fixed....

Thanks again

ChaffinYJ92 is offline   Reply With Quote
Unread 05-11-2013, 08:54 PM   #2
Jeepmanjoe52
Registered User
1997 TJ Wrangler 
 
Join Date: Apr 2011
Location: Tazewell, Tennessee
Posts: 71
Sounds like a capacitor issue on the circuit board. These store voltage and release as needed to boost another component on the board. It's bleeding off over night. That's why it works in the morning. Unfortunately it's new radio time, that is, unless you're pretty good with a soldering iron.
Jeepmanjoe52 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.