Turn signal,radio,cig lighter, wipers are out - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 09-29-2011, 03:49 PM Thread Starter
pohocker
Registered User
 
Join Date: Aug 2007
Location: Maryland
Posts: 2
Turn signal,radio,cig lighter, wipers are out

Folks, this is on my '99 Sahara. All other electrical components seem to be ok...head and fog lights, interior lights, gauges work fine. All fuses in the passenger compartment box are good. All fuses in the electrical power distribution center box under the hood are good-the ones I can visually check, anyway...the black cartridge fuses, who knows. Any suggestions that you can offer, I'd greatly appreciate.
Thanks.
Steve

pohocker is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-03-2011, 05:30 PM
writteninwax
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2010
Location: Wilmington
Posts: 14
Wow ...maybe its sunsPots or he'll of a coincidence but my 99 sahara just did the same thing. It got damp in the cap, and I've been adding lights,etc, but it's pretty odd. I haven't tried the lighter, but wipers and turn signal dead. Will dig in tomorrow if can get obit while the sun is up.... Keep u's posted
writteninwax is offline  
post #3 of 5 Old 10-03-2011, 05:35 PM Thread Starter
pohocker
Registered User
 
Join Date: Aug 2007
Location: Maryland
Posts: 2
I did some more Googling around about this. Some guys said that it was the ignition switch, so I went back out to mine and jiggled the key around in the switch while it was running, and things started to work again. Don't know what'll happen next time I try it, but it seems like that is a pretty solid lead on what's going wrong...thought you might like to know. Good luck!
pohocker is offline  
post #4 of 5 Old 10-04-2011, 05:49 AM
writteninwax
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2010
Location: Wilmington
Posts: 14
Quote:
Originally Posted by pohocker
I did some more Googling around about this. Some guys said that it was the ignition switch, so I went back out to mine and jiggled the key around in the switch while it was running, and things started to work again. Don't know what'll happen next time I try it, but it seems like that is a pretty solid lead on what's going wrong...thought you might like to know. Good luck!
Thanks. I will give that a try. !
writteninwax is offline  
post #5 of 5 Old 10-04-2011, 04:50 PM
writteninwax
Registered User
1999 TJ Wrangler 
 
Join Date: Oct 2010
Location: Wilmington
Posts: 14
Yep. Jiggling worked. May try to pull that ignition assembly and try to clean and tighten connections. In my spare time.....
writteninwax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Wipers, Turn signals, & Radio Not Working? Beastman1652 Audio, CB & Ham Radios, GPS, & Electrical 10 09-29-2012 12:14 PM
new cigarette lighter, now radio doesnt work mr_imposible Audio, CB & Ham Radios, GPS, & Electrical 6 05-27-2010 07:46 PM
Factory Radio Cutting Out (at high volume or with turn signal) JustChillin Audio, CB & Ham Radios, GPS, & Electrical 2 02-03-2010 02:13 PM
96 XJ Cigarette lighter/radio no power DrewzillaXJ Audio, CB & Ham Radios, GPS, & Electrical 2 12-22-2008 08:15 AM
Radio - need a ground, cig lighter good? zpmada Audio, CB & Ham Radios, GPS, & Electrical 8 02-01-2004 11:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome