Turn signal problem help - JeepForum.com

LinkBack Thread Tools
post #1 of 1 Old 06-26-2013, 07:37 PM Thread Starter
Registered User
Join Date: Jun 2013
Posts: 2
Turn signal problem help

I got a 2000 jeep grand cherokee about 5 months ago. I noticed that my turn signal on the rear driver side wasn't working. I replaced it, and it blew. I still had my right side working fine & the left side in the front did to, so I left it. I replaced my front parking lights and turn signals with blue lights & now when I push my left turn signal it stays solid, and the right one blinks like one of them is blown but they all work. (Except the rear left one). I visually checked the relay & it looks fine. Any help is greatly appreciated. Thanks!

cltnbac is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome