Turn signal issues.... 91 yj - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 12-11-2013, 10:36 PM Thread Starter
Nick2510
Registered User
 
Join Date: Dec 2013
Location: Memphis
Posts: 1
Turn signal issues.... 91 yj

Okay here is the problem, with the lights on the turn signals do not work or haz. The two arrows on the dash both stay lit up. With the lights off they work fine but seems like it takes them a few seconds before they start working. Taillights work just fine and so do the brake lights, but..... Only one brake light works when the lights are on but only Somtimes. The taillights do have the led bulb but don't think that would cause all the issues took them out and turned lights on and still both arrows lit up on dash. Any help? Thanks on advance

Nick2510 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome