Too much strain on the battery? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Too much strain on the battery?

NEW!! HMF 50"-52" light bar mounting brackets!! Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineYear End Clearance Sale! Save 20%

Reply
Unread 09-20-2004, 09:44 PM   #1
oldschool8604
Registered User
 
Join Date: Aug 2003
Location: Canada
Posts: 269
Too much strain on the battery?

Im not sure if im putting too much strain on my battery. nothing has happened, im just worried if i add more stuff. the only major things i have done are sub/amp, and LED lights.
I just want to know if im putting too much strain or if i add more lights or something if it will harm the battery..

__________________
89' Wagoneer Limited - The ShaGGiN' WaGGiN'
Blue Jeep Club Member #86

http://www.cardomain.com/id/oldschool8604
oldschool8604 is offline   Reply With Quote Quick reply to this message
Unread 09-21-2004, 12:23 AM   #2
Jerry Bransford
Administrator
 
Jerry Bransford's Avatar
2004 TJ Wrangler 
 
Join Date: Jan 2003
Location: Escondido, California, California
Posts: 60,946
No worries, your battery can put out more than enough amperes to take care of all of that plus more. Your alternator is what has to keep up with the drain since the total amperage draw of everything must be less than the alternator can put out or the battery will slowly drain over time.... which is far more rare than most people here would guess. Based on the things you've added, unless your amplifier is actually a bunch of Godzilla mega-watt amps used for contesting, your electrical system should be fine.
__________________
Getting Savvy...

Coolest offroad magazine ever! CRAWL Magazine

When you have a choice, buy American.
Jerry Bransford is online now   Reply With Quote Quick reply to this message
Unread 09-21-2004, 12:44 AM   #3
oldschool8604
Registered User
 
Join Date: Aug 2003
Location: Canada
Posts: 269
ok thanks! i was just kinda worried...but its all cleared up
__________________
89' Wagoneer Limited - The ShaGGiN' WaGGiN'
Blue Jeep Club Member #86

http://www.cardomain.com/id/oldschool8604
oldschool8604 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.