TJ Electrical Issue - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 12-20-2011, 04:20 PM Thread Starter
Rtrotter8
Registered User
2004 TJ Wrangler 
 
Join Date: Apr 2011
Location: Milton
Posts: 61
TJ Electrical Issue

Hey guys,

Ok so I went mudding today and go stuck a little on back in the trail, and I had decided that I would just use my winch to get myself out and not bother use to tow rope that my friend had. I jumped out of the car after I had turned it off, but kept the headlights on, and plugged it in and tried to let the line out, but once I hit the "out" button all the electrical just turned off. The headlights and the KC's or Fogs won't turn on now and my first guess was that I was a fuse? I have HID's installed in the headlights so it might possibly be the ballast too? Im not sure. The engine is fine except for a little smoke from right after getting off the trail but I'm sure that due to a little water I hope. Any help with the electrical issue would be amazing. Thank you. If it helps I also have a 2004 TJ.

Rtrotter8 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-20-2011, 09:37 PM
JPNinPA
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2011
Location: Dayton
Posts: 2,330
3 times a charm.

"Never look down on anyone unless your helping them up"- Jesse Jackson
JPNinPA is offline  
post #3 of 3 Old 12-21-2011, 12:11 AM Thread Starter
Rtrotter8
Registered User
2004 TJ Wrangler 
 
Join Date: Apr 2011
Location: Milton
Posts: 61
what?
Rtrotter8 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Electrical issue?" PCM? Zack87 Audio, CB & Ham Radios, GPS, & Electrical 1 08-15-2011 05:54 PM
94 GC electrical issue xslicerx Audio, CB & Ham Radios, GPS, & Electrical 0 04-20-2011 05:56 PM
Please help...electrical issue KATHYSCHMIDT Audio, CB & Ham Radios, GPS, & Electrical 8 07-23-2010 04:46 PM
Odd? Electrical Issue? Johnny5isAlive Audio, CB & Ham Radios, GPS, & Electrical 3 04-17-2007 12:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome