stock radio works but doesn't play sound - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > stock radio works but doesn't play sound

Rockridge 4WD IS Taking Zone Offroad Suspension Lift Kits FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Ring & Pinion's, Lockers, 4340 Axles, Install Kits, Ba

Reply
Unread 07-23-2013, 01:00 PM   #1
johnjames
Registered User
 
Join Date: Jul 2013
Posts: 3
stock radio works but doesn't play sound

I just got this 97 jeep grand cherokee limited but the radio was not in it so l put it back in but it doesn't play sound. this is my first jeep so can some one please help thanks

johnjames is offline   Reply With Quote Quick reply to this message
Unread 07-23-2013, 10:36 PM   #2
Indy
Registered User
 
Join Date: Oct 2004
Location: WY
Posts: 2,932
Does it have speakers?
__________________
Odds are im typing on a tablet. It takes too much effort to add some punctuation. Im lazy, get over it

Never underestimate the power of stupid.
Indy is offline   Reply With Quote Quick reply to this message
Unread 07-24-2013, 05:55 AM   #3
johnjames
Registered User
 
Join Date: Jul 2013
Posts: 3
Quote:
Originally Posted by Indy View Post
Does it have speakers?
The kid i got it off of took one out because it had water damage but i put a new one in from a junk yard
johnjames is offline   Reply With Quote Quick reply to this message
Unread 07-24-2013, 04:09 PM   #4
Glasssplinter
Registered User
1994 ZJ 
 
Join Date: Sep 2010
Location: Farmington
Posts: 192
Do you have the infinity system? Think the amp is under the rear seat. If so, you may have problems with that. Easiest thing is to buy an aftermarket stereo and bypass the infinity system if you have it and be done with it. Work better then factory stuff anyway.
__________________
'94 ZJ, 4.0L, 231 TC
Icom V-8000 with 1/4 wave
Glasssplinter is offline   Reply With Quote Quick reply to this message
Unread 07-27-2013, 04:42 PM   #5
johnjames
Registered User
 
Join Date: Jul 2013
Posts: 3
Quote:
Originally Posted by Glasssplinter View Post
Do you have the infinity system? Think the amp is under the rear seat. If so, you may have problems with that. Easiest thing is to buy an aftermarket stereo and bypass the infinity system if you have it and be done with it. Work better then factory stuff anyway.
Thank it was the amp just got one from the junk yard for now
johnjames is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.