Speaker issue. New db521 crackling. Not the speaker - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Speaker issue. New db521 crackling. Not the speaker

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe Solution to Radius Arm Bind - Meet Lock-N-LoadFS: Jeep Fog Light LED Bulbs! Several Brightness Options!

Reply
Unread 09-08-2012, 02:03 PM   #1
cinciwat
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2012
Location: cinicnnati, ohio
Posts: 12
Speaker issue. New db521 crackling. Not the speaker

Replaced dash and soundbar speakers with DB521 Polk 5.25 inch. They sound awesome but... One of the soundbar (passanger side) speakers positions is static/crackling. It is not the speaker because i swapped one of the other new speakes in the same soundbar spot and it had the same issue. The other three are fine. Great in fact!

What could the issue be with that one soundbar speaker hookup? Wondering where to start looking.

cinciwat is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 06:25 AM   #2
cinciwat
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2012
Location: cinicnnati, ohio
Posts: 12
Come on people. I have fixed every problem i have posted. Someone has to have had this issue. The problem stays in the one soundbar casing. Swapping speakers around the issue does NOT follow the speaker but remains in that spot. I have reversed the + and - and looked for anything else. Both dash and other soundbar sound awesome so just need an idea of what this could be. Before i take it apart would like some expert advice on where to start.
cinciwat is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 07:01 AM   #3
Ironhead
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2011
Location: Westchester, Illinois
Posts: 3,161
wow, calm down there speedy, this section doesnt get as much traffic as others. and fixed every problem you have posted? you have 9 posts

i have the same issue, found that if I touch the light next to the buzzing speaker, it sounds perfect. havent gotten around to dropping the speaker and finding a solution, but it is probably the light
Ironhead is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 01:52 PM   #4
cinciwat
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2012
Location: cinicnnati, ohio
Posts: 12
Nice ironhead. Never been patient. Not speedy either. Just a little torked i dropped the $$ and time to put 4 speakers and subwoofer in only to have the one pesky issue.

You were right. For some reason the light was causing the static. Took the light out and pulled wires back and the static is gone. I cut the origional tape away that was holding them together and taped the light wires seperate from the speaker wires starting at the entry point. Hooked everything back up and sounds fine.

As for the nine posts. You have to start somewhere. Now at 10. BAMB!
cinciwat is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 03:13 PM   #5
Ironhead
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2011
Location: Westchester, Illinois
Posts: 3,161
thanks for the info, it's annoying as hell and i havent had any time. i thought i blew one of my polk momo's and was messing with everything. touched the light and fixed everything. good to know that all i need to do is tape up the wires. i was waiting to open it up cause i am going to add some floss too

Ironhead is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 06:01 PM   #6
mKosel
Registered User
1999 WJ 
 
Join Date: Aug 2012
Location: Fargo, ND
Posts: 255
What light? (car noob speaking)
mKosel is offline   Reply With Quote Quick reply to this message
Unread 09-09-2012, 08:58 PM   #7
cinciwat
Registered User
2004 TJ Wrangler 
 
Join Date: Aug 2012
Location: cinicnnati, ohio
Posts: 12
The light i am talking about is in the soundbar. My soundbar has a dome light next to the speaker and inside the casing the wires were taped together.
cinciwat is offline   Reply With Quote Quick reply to this message
Unread 10-02-2012, 11:00 AM   #8
Ironhead
Registered User
2003 TJ Wrangler 
 
Join Date: Jan 2011
Location: Westchester, Illinois
Posts: 3,161
did that permanently fix the issue? I dont use the factory speaker wire, so i just taped the pigtail to the light wires. it was better, but still had some vibrations. ended up making a gasket out of a bud light case, and fit it between the light housing and the speaker pod. no more vibes, and only a few minutes of work
Ironhead is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.