Rear wiper, and squirts - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 10-05-2011, 07:28 PM Thread Starter
Myg
Registered User
 
Join Date: Sep 2011
Posts: 1
Rear wiper, and squirts

I've got a 07 liberty and my rear wiper doesn't work, and both my front and rear squirts aren't working. My front wipers work completely. I've checked all fuses but can't find any reason for this. Any help would be greatly appreciated.

Myg is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 10-06-2011, 04:02 PM
JPNinPA
Registered User
2005 LJ Wrangler 
 
Join Date: Feb 2011
Location: Dayton
Posts: 2,330
Welcome to the board and sorry your not feeling well. If it's bad enough you have to front wipe you really got troubles.


Couldn't help it. Check the connectors on teh pump located at teh bottom of the washer fluid reservoir. This might help you squirts problem.

"Never look down on anyone unless your helping them up"- Jesse Jackson
JPNinPA is offline  
post #3 of 3 Old 10-07-2011, 08:51 AM
tennman1990
Registered User
2001 TJ Wrangler 
 
Join Date: Feb 2011
Location: Knoxville
Posts: 74
Quote:
Originally Posted by JPNinPA View Post
Check the connectors on teh pump located at teh bottom of the washer fluid reservoir. This might help you squirts problem.
This. And then if you have the ability to I would take a voltmeter to that back wiper motor and check to see that power is being delivered back there as it is supposed to.
If not - Bad fuse/wiring/relay to front of vehicle
If so - bad motor

From ZJ to TJ.
tennman1990 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome