Only left speakers putting out sound from MyGig - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Only left speakers putting out sound from MyGig

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsSave at JeepHut on Smittybilt Soft tops

Reply
Unread 05-01-2014, 08:56 PM   #1
Bzwth
Registered User
2008 WK 
 
Join Date: Feb 2009
Location: Dallas, TX
Posts: 54
Only left speakers putting out sound from MyGig

The right channels front/back are inop on my sound system. I have an 08 Grand Cherokee Overland with a MyGiG. I was told by the dealer, after trouble shooting, that the MyGiG unit itself was not putting out a right channel signal to the amplifier. My unit has nav, sirius, DVD, camera, Uconnect, etc.

If I were to get a replacement MyGiG unit on ebay, should I look for a later model that has improved features than my 08 MyGig? If so, what should I look for?

Or would anyone know of a fix?

Thanks.

Bzwth is offline   Reply With Quote
Unread 05-14-2014, 07:46 PM   #2
Bzwth
Registered User
2008 WK 
 
Join Date: Feb 2009
Location: Dallas, TX
Posts: 54
Took my WK to an audio shop and they wanted to verify what the dealer had said, so they swapped MyGiG units for trouble shooting purposes. Still no right channel sound being produced with a different MyGiG unit installed. Apparently the dealer was full of it when they told me they verified the problem to be in my MyGIG unit. They wanted over $1000 to replace my MyGiG with a refurb.

Amplifier?
Bzwth is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.