need electrical help... - JeepForum.com
 
LinkBack Thread Tools
post #1 of 5 Old 11-30-2012, 08:13 PM Thread Starter
cvaria
Registered User
 
Join Date: Jan 2007
Location: Tallahassee
Posts: 407
need electrical help...

My radio (aftermarket) stopped working in my tj. it was going in and out for a while, must have been a short. It has now fully quit... i though it was the radio so i bought and installed another one..not the radio same issue, no power to the radio. i checked EVERY fuse in the interior fusebox, i think have bad wiring somewhere, maybe mice.

when the radio/a radio is not in the din (not wired) and i turn off the jeep, it is normal silence. when a radio is in the din (wired) and i turn off the jeep, i get a quick buzz noise that goes away. the noise comes from behind the steering wheel. is there a wring hub back there in trouble? I can't find a good tj (non-sub woofer) wiring diagram.

has anyone else been here?


-----------------------------------------------------
I like my 2003 Z4 2.5i... but love my 2002 Wrangler SE and my 2007 sportster 883/1200 conversion! :rofl:
-----------------------------------------------------
cvaria is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-30-2012, 09:13 PM
Rubi4MyMrs
Web Wheeler
 
Rubi4MyMrs's Avatar
2005 LJ Wrangler 
 
Join Date: Mar 2011
Location: Trails of
Posts: 3,200
You do have 2 power wires one switched & one B+. The switched is fuse15 in the block behind the glove box the B+ is fuse 24 in the PDC in front of the battery. For the wiring diagram the FSM has both with & without the sub.




Power to fuse 15 comes from the ignition switch so make sure the wipers & turn signals are working or the switch may be bad.


See online read only FSMs here:
http://www.jeep4x4center.com/knowled...ex.htm#service
You may have to go to the bottom of the page & pick Jeep Resources & online manuals if it directs you to home page rather than the knowledge base.
Rubi4MyMrs is offline  
post #3 of 5 Old 12-01-2012, 04:26 PM Thread Starter
cvaria
Registered User
 
Join Date: Jan 2007
Location: Tallahassee
Posts: 407
Super useful response! i love the forums.. i'll go out and take a look in the morning

-----------------------------------------------------
I like my 2003 Z4 2.5i... but love my 2002 Wrangler SE and my 2007 sportster 883/1200 conversion! :rofl:
-----------------------------------------------------
cvaria is offline  
post #4 of 5 Old 12-05-2012, 06:41 AM
PATJ1998
Registered User
1998 TJ Wrangler 
 
Join Date: Jun 2010
Location: Nanticoke/Wilkes-Barre
Posts: 5
Hey man lemme know how it works out for ya, mine is doing the same thing, turns on randomly, don't know if it fully quit cuz the last time it was off for about a month then came back on for 2 days now it's back off
PATJ1998 is offline  
post #5 of 5 Old 07-19-2013, 11:19 AM Thread Starter
cvaria
Registered User
 
Join Date: Jan 2007
Location: Tallahassee
Posts: 407
It was the antenna cable causing the issue. It had wiggled loose. If the antenna is not connected the rqdio will not work. Pull out the glove compartment and adjust the cable on the back of the radio

-----------------------------------------------------
I like my 2003 Z4 2.5i... but love my 2002 Wrangler SE and my 2007 sportster 883/1200 conversion! :rofl:
-----------------------------------------------------
cvaria is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome