Heater, wiper blades, and radio. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > General Technical Discussions > Electrical, Audio, GPS, & 2-Way Radio > Heater, wiper blades, and radio.

Labor Day Sale!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitEngo winches available at www.rockridge4wd.com! Free shipp

Reply
Unread 02-09-2014, 10:31 AM   #1
92briarwood
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2013
Location: Arcadia, Indiana
Posts: 52
Heater, wiper blades, and radio.

I'm trying to figure out why all three of these aren't working. It started when I replaced my lock cylinder. They worked fine before I did that and now the don't work. I checked fuses and all of them are fine. Any info would help.

92briarwood is offline   Reply With Quote
Unread 02-11-2014, 07:20 PM   #2
archerro
Registered User
 
Join Date: Jan 2014
Location: College Station, Texas
Posts: 9
How did you check them? Just looking at a fuse can be very deceiving. If you don't have a multimeter to check the voltage at each side of the fuse for that circuit, then just go ahead and replace it anyways and see if that fixes your problem.
archerro is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.