post #1 of Old 06-06-2013, 05:56 PM Thread Starter
richybeattie
Registered User
1998 ZJ 
 
Join Date: May 2013
Location: Chicago
Posts: 1
GC ZJ 98 Stereo problem

Newbie here. Need some advice from the forum.

Grand Cherokee ZJ 1998 4.0 limited with stock radio and infinity gold amp and speakers. The head unit turns on and I can hear a signal to all of the speakers, but it's distant and seems unamplified. I bought a reconditioned infinity amp and it's made no difference.
Before I go buying a replacement head unit (I want to stay totally stock), I wondered if anyone had any idea what the cause is? I've practically no electrical knowledge, so be gentle!
Rich

richybeattie is offline  
post #2 of Old 06-07-2013, 01:54 PM
4x4fun
Registered User
2001 TJ Wrangler 
 
Join Date: Nov 2011
Location: Livonia
Posts: 20
I would check the speaker wiring and make sure they are not wired back words
4x4fun is offline  
post #3 of Old 06-21-2013, 06:31 PM
MattZJ98
Registered User
1998 ZJ 
 
Join Date: Jun 2013
Location: Acworth
Posts: 2
Have a problem a lot like yours where sometimes all the power comes through the amp and you can really Jam to the nice speakers....... lol but that's 10% of the time when they all actually function so im always turning the nob UP UP UP! 98 ZJ limited
MattZJ98 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome